summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-26 23:21:42 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-26 23:21:42 +0000
commit591cf940b9dc5267f9790c50c008f5a481bf614d (patch)
treed02f5e45c76a813d364255b8c49061c510bfd181 /dev-lisp/cl-tbnl
parentstable on x86 (diff)
downloadgentoo-2-591cf940b9dc5267f9790c50c008f5a481bf614d.tar.gz
gentoo-2-591cf940b9dc5267f9790c50c008f5a481bf614d.tar.bz2
gentoo-2-591cf940b9dc5267f9790c50c008f5a481bf614d.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp/cl-tbnl')
-rw-r--r--dev-lisp/cl-tbnl/ChangeLog7
-rw-r--r--dev-lisp/cl-tbnl/Manifest2
-rw-r--r--dev-lisp/cl-tbnl/cl-tbnl-0.5.2.ebuild38
-rw-r--r--dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.5.21
4 files changed, 47 insertions, 1 deletions
diff --git a/dev-lisp/cl-tbnl/ChangeLog b/dev-lisp/cl-tbnl/ChangeLog
index da14bccab3e4..b9c873a3becf 100644
--- a/dev-lisp/cl-tbnl/ChangeLog
+++ b/dev-lisp/cl-tbnl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-tbnl
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.5 2005/03/19 21:20:44 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/ChangeLog,v 1.6 2005/03/26 23:21:42 mkennedy Exp $
+
+*cl-tbnl-0.5.2 (26 Mar 2005)
+
+ 26 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +cl-tbnl-0.5.2.ebuild:
+ New upstream version.
*cl-tbnl-0.5.1 (19 Mar 2005)
diff --git a/dev-lisp/cl-tbnl/Manifest b/dev-lisp/cl-tbnl/Manifest
index e7132e85d8cd..d446c776136e 100644
--- a/dev-lisp/cl-tbnl/Manifest
+++ b/dev-lisp/cl-tbnl/Manifest
@@ -7,6 +7,7 @@ MD5 0d1f4e17c59a3b0325807341d6efc04d cl-tbnl-0.3.12.ebuild 923
MD5 959fd151be631d3deb7c78f314d1cae9 cl-tbnl-0.3.13.ebuild 923
MD5 93d2851f8c41f2d64497dc6f80fe00bf cl-tbnl-0.4.1.ebuild 922
MD5 10735e96e910915989ba829b8c996ab5 cl-tbnl-0.5.1.ebuild 922
+MD5 10735e96e910915989ba829b8c996ab5 cl-tbnl-0.5.2.ebuild 922
MD5 8bc422e5dac6886c3c688ffd6ed93dd6 files/digest-cl-tbnl-0.2.12 62
MD5 96bbbd53007caa5cc06cc59bcb68c1ff files/digest-cl-tbnl-0.3.10 62
MD5 a85a52d1daff75e4574ebd35622844f5 files/digest-cl-tbnl-0.3.11 67
@@ -14,3 +15,4 @@ MD5 5764ebffe3c1d612b13d29a2494df2eb files/digest-cl-tbnl-0.3.12 67
MD5 e5ef74a2e8ed899318b177f8a554db55 files/digest-cl-tbnl-0.3.13 67
MD5 650b3eb0a9f443c6bcd6b083cdb71a49 files/digest-cl-tbnl-0.4.1 66
MD5 338294c378c9cfa6c701c7e004c39476 files/digest-cl-tbnl-0.5.1 66
+MD5 e91bbe8a494a0fa85f3f86313792b3a8 files/digest-cl-tbnl-0.5.2 66
diff --git a/dev-lisp/cl-tbnl/cl-tbnl-0.5.2.ebuild b/dev-lisp/cl-tbnl/cl-tbnl-0.5.2.ebuild
new file mode 100644
index 000000000000..9828059828e4
--- /dev/null
+++ b/dev-lisp/cl-tbnl/cl-tbnl-0.5.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-tbnl/cl-tbnl-0.5.2.ebuild,v 1.1 2005/03/26 23:21:42 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="TBNL is a toolkit for building dynamic websites with Common Lisp based on mod_lisp."
+HOMEPAGE="http://www.weitz.de/tbnl/"
+SRC_URI="mirror://gentoo/tbnl_${PV}.orig.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="apache2"
+
+DEPEND="dev-lisp/cl-kmrcl
+ dev-lisp/cl-md5
+ dev-lisp/cl-base64
+ dev-lisp/cl-url-rewrite
+ dev-lisp/cl-ppcre"
+
+# RDEPEND="${DEPEND}
+# apache2? ( www-apache/mod_lisp2 ) !apache2? ( www-apache/mod_lisp )"
+
+RDEPEND="${DEPEND}
+ www-apache/mod_lisp"
+
+S=${WORKDIR}/tbnl-${PV}
+
+CLPACKAGE=tbnl
+
+src_install() {
+ common-lisp-install *.lisp *.asd
+ common-lisp-system-symlink
+ dodoc CHANGELOG README
+ dohtml doc/index.html
+ docinto test
+ dodoc test/*
+}
diff --git a/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.5.2 b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.5.2
new file mode 100644
index 000000000000..329082124295
--- /dev/null
+++ b/dev-lisp/cl-tbnl/files/digest-cl-tbnl-0.5.2
@@ -0,0 +1 @@
+MD5 b26bae036de68f37a9d77a51ea1f5412 tbnl_0.5.2.orig.tar.gz 85994