summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-05-13 11:36:55 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-05-13 11:36:55 +0000
commit3fd33bf5ae89de68ba5e815b0f71187a57396a77 (patch)
tree6a4add554c30248b9a08662939d039d40b1e0bfd /dev-lisp/clisp
parentbump, bug 218739 and fix bug 155402, thanks to Stelian Ionescu <stelian.iones... (diff)
downloadgentoo-2-3fd33bf5ae89de68ba5e815b0f71187a57396a77.tar.gz
gentoo-2-3fd33bf5ae89de68ba5e815b0f71187a57396a77.tar.bz2
gentoo-2-3fd33bf5ae89de68ba5e815b0f71187a57396a77.zip
drop old versions
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.38-r1.ebuild104
-rw-r--r--dev-lisp/clisp/clisp-2.38-r2.ebuild126
-rw-r--r--dev-lisp/clisp/clisp-2.38.ebuild104
-rw-r--r--dev-lisp/clisp/clisp-2.39.ebuild124
-rw-r--r--dev-lisp/clisp/clisp-2.41.ebuild93
-rw-r--r--dev-lisp/clisp/clisp-2.42-r1.ebuild102
-rw-r--r--dev-lisp/clisp/clisp-2.42.ebuild75
-rw-r--r--dev-lisp/clisp/clisp-2.43.ebuild96
9 files changed, 7 insertions, 825 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index dbd6eedbac7d..dacf5849f568 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.76 2008/05/13 11:33:40 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.77 2008/05/13 11:36:55 hkbst Exp $
+
+ 13 May 2008; Marijn Schouten <hkBst@gentoo.org> -clisp-2.38.ebuild,
+ -clisp-2.38-r1.ebuild, -clisp-2.38-r2.ebuild, -clisp-2.39.ebuild,
+ -clisp-2.41.ebuild, -clisp-2.42.ebuild, -clisp-2.42-r1.ebuild,
+ -clisp-2.43.ebuild:
+ drop old versions
*clisp-2.44.1 (13 May 2008)
diff --git a/dev-lisp/clisp/clisp-2.38-r1.ebuild b/dev-lisp/clisp/clisp-2.38-r1.ebuild
deleted file mode 100644
index 765d27238c02..000000000000
--- a/dev-lisp/clisp/clisp-2.38-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.38-r1.ebuild,v 1.3 2007/07/22 10:36:10 grobian Exp $
-
-inherit flag-o-matic common-lisp-common-2 eutils toolchain-funcs
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="X fastcgi pcre postgres readline zlib"
-
-RDEPEND="dev-libs/libsigsegv
- >=dev-lisp/common-lisp-controller-4.27
- sys-devel/gettext
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- X? ( x11-libs/libXpm )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- X? ( x11-misc/imake x11-proto/xextproto )"
-
-PROVIDE="virtual/commonlisp"
-
-src_compile() {
- # Let CLISP use its own set of optimizations
- unset CFLAGS CXXFLAGS
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi
- --with-module=wildcard
- --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- use X && myconf="${myconf} --with-module=clx/new-clx"
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
- einfo "Configuring with ${myconf}"
- ./configure --prefix=/usr ${myconf} build || die "./configure failed"
- cd build
- ./makemake ${myconf} >Makefile
- emake -j1 config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
- emake -j1 || die
-}
-
-src_install() {
- pushd build
- make DESTDIR=${D} prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
- ANNOUNCE clisp.dvi clisp.html
- rm -f ${D}/usr/lib/clisp/base/*
- (cd ${D}/usr/lib/clisp/base && ln -s ../full/* .)
- chmod a+x ${D}/usr/lib/clisp/clisp-link
- popd
- # install common-lisp-controller profile
- exeinto /usr/lib/common-lisp/bin
- doexe ${FILESDIR}/${PV}/clisp.sh
- insinto /usr/lib/clisp
- doins ${FILESDIR}/${PV}/install-clc.lisp
- dodoc ${FILESDIR}/${PV}/README.Gentoo
- keepdir /usr/lib/common-lisp/clisp
-
- dohtml doc/impnotes.{css,html}
- dohtml build/clisp.html
- dohtml doc/clisp.png
- dodoc build/clisp.{ps,pdf}
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
-
-pkg_preinst() {
- local clisp_dir=/usr/lib/clisp
- local old_mem=$clisp_dir/full/lispinit.mem
- local new_mem=$clisp_dir/full/lispinit-new.mem
- local clean_mem=$clisp_dir/full/lispinit-clean.mem
- local lisp_run=$clisp_dir/full/lisp.run
- rm -f $old_mem $new_mem $clean_mem $lisp_run
-}
-
-pkg_postinst() {
- standard-impl-postinst clisp
-}
-
-pkg_postrm() {
- standard-impl-postrm clisp /usr/bin/clisp
-}
-
-pkg_postrm() {
- if [ ! -x /usr/bin/clisp ]; then
- rm -rf /usr/lib/clisp/ || die
- fi
-}
diff --git a/dev-lisp/clisp/clisp-2.38-r2.ebuild b/dev-lisp/clisp/clisp-2.38-r2.ebuild
deleted file mode 100644
index 2c7128057903..000000000000
--- a/dev-lisp/clisp/clisp-2.38-r2.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.38-r2.ebuild,v 1.5 2007/07/22 10:36:10 grobian Exp $
-
-inherit flag-o-matic common-lisp-common-2 eutils toolchain-funcs
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="X new-clx fastcgi pcre postgres readline zlib"
-
-RDEPEND="dev-libs/libsigsegv
- >=dev-lisp/common-lisp-controller-4.27
- sys-devel/gettext
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-
-DEPEND="${RDEPEND}
- X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-pkg_setup() {
- if use X; then
- if use new-clx; then
- elog "CLISP will be built with NEW-CLX support which is a C binding to Xorg libraries."
- else
- elog "CLISP will be built with MIT-CLX support."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/${PV}/fastcgi-Makefile-gentoo.patch
-}
-
-src_compile() {
- # Let CLISP use its own set of optimizations
- unset CFLAGS CXXFLAGS
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi
- --with-module=wildcard
- --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- if use X; then
- if use new-clx; then
- myconf="${myconf} --with-module=clx/new-clx"
- else
- myconf="${myconf} --with-module=clx/mit-clx"
- fi
- fi
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
- einfo "Configuring with ${myconf}"
- ./configure --prefix=/usr ${myconf} build || die "./configure failed"
- cd build
- ./makemake ${myconf} >Makefile
- emake -j1 config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
- emake -j1 || die
-}
-
-src_install() {
- pushd build
- make DESTDIR=${D} prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
- ANNOUNCE clisp.dvi clisp.html
- rm -f ${D}/usr/lib/clisp/base/*
- (cd ${D}/usr/lib/clisp/base && ln -s ../full/* .)
- chmod a+x ${D}/usr/lib/clisp/clisp-link
- popd
- # install common-lisp-controller profile
- exeinto /usr/lib/common-lisp/bin
- doexe ${FILESDIR}/${PV}/clisp.sh
- insinto /usr/lib/clisp
- doins ${FILESDIR}/${PV}/install-clc.lisp
- dodoc ${FILESDIR}/${PV}/README.Gentoo
- keepdir /usr/lib/common-lisp/clisp
-
- dohtml doc/impnotes.{css,html}
- dohtml build/clisp.html
- dohtml doc/clisp.png
- dodoc build/clisp.{ps,pdf}
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
-
-pkg_preinst() {
- local clisp_dir=/usr/lib/clisp
- local old_mem=$clisp_dir/full/lispinit.mem
- local new_mem=$clisp_dir/full/lispinit-new.mem
- local clean_mem=$clisp_dir/full/lispinit-clean.mem
- local lisp_run=$clisp_dir/full/lisp.run
- rm -f $old_mem $new_mem $clean_mem $lisp_run
-}
-
-pkg_postinst() {
- standard-impl-postinst clisp
-}
-
-pkg_postrm() {
- standard-impl-postrm clisp /usr/bin/clisp
-}
-
-pkg_postrm() {
- if [ ! -x /usr/bin/clisp ]; then
- rm -rf /usr/lib/clisp/ || die
- fi
-}
diff --git a/dev-lisp/clisp/clisp-2.38.ebuild b/dev-lisp/clisp/clisp-2.38.ebuild
deleted file mode 100644
index 8cf2d2fa9429..000000000000
--- a/dev-lisp/clisp/clisp-2.38.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.38.ebuild,v 1.5 2007/07/22 10:36:10 grobian Exp $
-
-inherit flag-o-matic common-lisp-common-2 eutils toolchain-funcs
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ppc -sparc x86"
-IUSE="X fastcgi pcre postgres readline zlib"
-
-RDEPEND="dev-libs/libsigsegv
- >=dev-lisp/common-lisp-controller-4.27
- sys-devel/gettext
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- X? ( x11-libs/libXpm )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )"
-DEPEND="${RDEPEND}
- X? ( x11-proto/xextproto )"
-
-PROVIDE="virtual/commonlisp"
-
-src_compile() {
- # Let CLISP use its own set of optimizations
- unset CFLAGS CXXFLAGS
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi
- --with-module=wildcard
- --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- use X && myconf="${myconf} --with-module=clx/new-clx"
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
- einfo "Configuring with ${myconf}"
- ./configure --prefix=/usr ${myconf} build || die "./configure failed"
- cd build
- ./makemake ${myconf} >Makefile
- emake -j1 config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
- emake -j1 || die
-}
-
-src_install() {
- pushd build
- make DESTDIR=${D} prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
- ANNOUNCE clisp.dvi clisp.html
- rm -f ${D}/usr/lib/clisp/base/*
- (cd ${D}/usr/lib/clisp/base && ln -s ../full/* .)
- chmod a+x ${D}/usr/lib/clisp/clisp-link
- popd
- # install common-lisp-controller profile
- exeinto /usr/lib/common-lisp/bin
- doexe ${FILESDIR}/${PV}/clisp.sh
- insinto /usr/lib/clisp
- doins ${FILESDIR}/${PV}/install-clc.lisp
- dodoc ${FILESDIR}/${PV}/README.Gentoo
- keepdir /usr/lib/common-lisp/clisp
-
- dohtml doc/impnotes.{css,html}
- dohtml build/clisp.html
- dohtml doc/clisp.png
- dodoc build/clisp.{ps,pdf}
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
-
-pkg_preinst() {
- local clisp_dir=/usr/lib/clisp
- local old_mem=$clisp_dir/full/lispinit.mem
- local new_mem=$clisp_dir/full/lispinit-new.mem
- local clean_mem=$clisp_dir/full/lispinit-clean.mem
- local lisp_run=$clisp_dir/full/lisp.run
- rm -f $old_mem $new_mem $clean_mem $lisp_run
-}
-
-pkg_postinst() {
- standard-impl-postinst clisp
-}
-
-pkg_postrm() {
- standard-impl-postrm clisp /usr/bin/clisp
-}
-
-pkg_postrm() {
- if [ ! -x /usr/bin/clisp ]; then
- rm -rf /usr/lib/clisp/ || die
- fi
-}
diff --git a/dev-lisp/clisp/clisp-2.39.ebuild b/dev-lisp/clisp/clisp-2.39.ebuild
deleted file mode 100644
index 43c23f611256..000000000000
--- a/dev-lisp/clisp/clisp-2.39.ebuild
+++ /dev/null
@@ -1,124 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.39.ebuild,v 1.4 2007/07/22 10:36:10 grobian Exp $
-
-inherit flag-o-matic common-lisp-common-2 eutils toolchain-funcs
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="X new-clx fastcgi pcre postgres readline zlib"
-
-RDEPEND=">=dev-libs/libsigsegv-2.4
- >=dev-lisp/common-lisp-controller-4.27
- sys-devel/gettext
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-
-DEPEND="${RDEPEND}
- X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-pkg_setup() {
- if use X; then
- if use new-clx; then
- einfo "CLISP will be built with NEW-CLX support which is a C binding to Xorg libraries."
- else
- einfo "CLISP will be built with MIT-CLX support."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- epatch ${FILESDIR}/${PV}/fastcgi-Makefile-gentoo.patch
-}
-
-src_compile() {
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi
- --with-module=wildcard
- --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- if use X; then
- if use new-clx; then
- myconf="${myconf} --with-module=clx/new-clx"
- else
- myconf="${myconf} --with-module=clx/mit-clx"
- fi
- fi
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
- einfo "Configuring with ${myconf}"
- ./configure --prefix=/usr ${myconf} build || die "./configure failed"
- cd build
- ./makemake ${myconf} >Makefile
- emake -j1 config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
- emake -j1 || die
-}
-
-src_install() {
- pushd build
- make DESTDIR=${D} prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
- ANNOUNCE clisp.dvi clisp.html
- rm -f ${D}/usr/lib/clisp/base/*
- (cd ${D}/usr/lib/clisp/base && ln -s ../full/* .)
- chmod a+x ${D}/usr/lib/clisp/clisp-link
- popd
- # install common-lisp-controller profile
- exeinto /usr/lib/common-lisp/bin
- doexe ${FILESDIR}/${PV}/clisp.sh
- insinto /usr/lib/clisp
- doins ${FILESDIR}/${PV}/install-clc.lisp
- dodoc ${FILESDIR}/${PV}/README.Gentoo
- keepdir /usr/lib/common-lisp/clisp
-
- dohtml doc/impnotes.{css,html}
- dohtml build/clisp.html
- dohtml doc/clisp.png
- dodoc build/clisp.{ps,pdf}
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
-
-pkg_preinst() {
- local clisp_dir=/usr/lib/clisp
- local old_mem=$clisp_dir/full/lispinit.mem
- local new_mem=$clisp_dir/full/lispinit-new.mem
- local clean_mem=$clisp_dir/full/lispinit-clean.mem
- local lisp_run=$clisp_dir/full/lisp.run
- rm -f $old_mem $new_mem $clean_mem $lisp_run
-}
-
-pkg_postinst() {
- standard-impl-postinst clisp
-}
-
-pkg_postrm() {
- standard-impl-postrm clisp /usr/bin/clisp
-}
-
-pkg_postrm() {
- if [ ! -x /usr/bin/clisp ]; then
- rm -rf /usr/lib/clisp/ || die
- fi
-}
diff --git a/dev-lisp/clisp/clisp-2.41.ebuild b/dev-lisp/clisp/clisp-2.41.ebuild
deleted file mode 100644
index eb32406e2d70..000000000000
--- a/dev-lisp/clisp/clisp-2.41.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.41.ebuild,v 1.9 2007/09/09 18:01:53 josejx Exp $
-
-inherit flag-o-matic eutils toolchain-funcs
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ppc -sparc x86"
-IUSE="X new-clx fastcgi pcre postgres readline zlib"
-
-RDEPEND=">=dev-libs/libsigsegv-2.4
- sys-devel/gettext
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-
-DEPEND="${RDEPEND}
- X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-pkg_setup() {
- if use X; then
- if use new-clx; then
- elog "CLISP will be built with NEW-CLX support which is a C binding to Xorg libraries."
- else
- elog "CLISP will be built with MIT-CLX support."
- fi
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch ${FILESDIR}/2.41-fastcgi-Makefile-gentoo.patch
- epatch ${FILESDIR}/2.41-fastcgi-build.patch
- epatch ${FILESDIR}/2.41-linux-headers.patch
-}
-
-src_compile() {
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi
- --with-module=wildcard
- --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- if use X; then
- if use new-clx; then
- myconf="${myconf} --with-module=clx/new-clx"
- else
- myconf="${myconf} --with-module=clx/mit-clx"
- fi
- fi
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
- einfo "Configuring with ${myconf}"
- ./configure --prefix=/usr ${myconf} build || die "./configure failed"
- cd build
- ./makemake ${myconf} >Makefile
- emake -j1 config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- sed -i 's,http://www.lisp.org/HyperSpec/,http://www.lispworks.com/reference/HyperSpec/,g' config.lisp
- emake -j1 || die
-}
-
-src_install() {
- pushd build
- make DESTDIR=${D} prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add GNU-GPL COPYRIGHT \
- ANNOUNCE clisp.dvi clisp.html
- chmod a+x ${D}/usr/lib/clisp/clisp-link
- popd
- dohtml doc/impnotes.{css,html}
- dohtml build/clisp.html
- dohtml doc/clisp.png
- dodoc build/clisp.ps
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.42-r1.ebuild b/dev-lisp/clisp/clisp-2.42-r1.ebuild
deleted file mode 100644
index f1820b0b669f..000000000000
--- a/dev-lisp/clisp/clisp-2.42-r1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.42-r1.ebuild,v 1.2 2007/12/22 19:18:34 nixnut Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
-
-RDEPEND="dev-lisp/gentoo-init
- >=dev-libs/libsigsegv-2.4
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-# * GNU gettext
-# + Not needed on systems with glibc 2.2 or newer, but recommended on all
-# other systems: needed if you want clisp with native language support.
-# sys-devel/gettext
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-src_unpack() {
- unpack ${A}
- # Fix module install path: 2.41.1 -> 2.42
- sed -i 's:2\.41\.1:2\.42:' "${S}"/src/{configure,version.h}
-}
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-src_compile() {
- CC="$(tc-getCC)"
-
- # built-in features
- local myconf="--with-dynamic-ffi"
- use readline || myconf="${myconf} --with-noreadline"
-
- # default modules
- enable_modules wildcard rawsock i18n
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- ./makemake ${myconf} > Makefile
-# emake config.lisp
-# sed -i 's,"vi","nano",g' config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp/clisp-link
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.42.ebuild b/dev-lisp/clisp/clisp-2.42.ebuild
deleted file mode 100644
index ac8fa5bfcf75..000000000000
--- a/dev-lisp/clisp/clisp-2.42.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.42.ebuild,v 1.3 2007/10/17 14:09:32 hkbst Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="X new-clx fastcgi pcre postgres readline zlib"
-
-RDEPEND=">=dev-libs/libsigsegv-2.4
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-# * GNU gettext
-# + Not needed on systems with glibc 2.2 or newer, but recommended on all
-# other systems: needed if you want clisp with native language support.
-# sys-devel/gettext
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-BUILDDIR="builddir"
-
-src_compile() {
- CC="$(tc-getCC)"
- local myconf="--with-dynamic-ffi --with-module=wildcard --with-module=rawsock"
- use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
- use readline || myconf="${myconf} --with-noreadline"
- if use X; then
- if use new-clx; then
- myconf="${myconf} --with-module=clx/new-clx"
- else
- myconf="${myconf} --with-module=clx/mit-clx"
- fi
- fi
- if use postgres; then
- myconf="${myconf} --with-module=postgresql"
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && myconf="${myconf} --with-module=fastcgi"
- use pcre && myconf="${myconf} --with-module=pcre"
- use zlib && myconf="${myconf} --with-module=zlib"
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- ./makemake ${myconf} >Makefile
- emake config.lisp
- sed -i 's,"vi","nano",g' config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp/clisp-link
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.43.ebuild b/dev-lisp/clisp/clisp-2.43.ebuild
deleted file mode 100644
index 941fbce4c3c8..000000000000
--- a/dev-lisp/clisp/clisp-2.43.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.43.ebuild,v 1.4 2007/12/08 16:54:36 drac Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="amd64 ~ppc64 -sparc ~x86"
-IUSE="X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
-
-RDEPEND="dev-lisp/gentoo-init
- >=dev-libs/libsigsegv-2.4
- virtual/tetex
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-# * GNU gettext
-# + Not needed on systems with glibc 2.2 or newer, but recommended on all
-# other systems: needed if you want clisp with native language support.
-# sys-devel/gettext
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-src_compile() {
- CC="$(tc-getCC)"
-
- # built-in features
- local myconf="--with-dynamic-ffi"
- use readline || myconf="${myconf} --with-noreadline"
-
- # default modules
- enable_modules wildcard rawsock i18n
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- ./makemake ${myconf} > Makefile
-# emake config.lisp
-# sed -i 's,"vi","nano",g' config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp/clisp-link
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}