summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-07-29 11:32:46 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-07-29 11:32:46 +0000
commitb7ce18d399cb9714aca7ab0c769cf18fe1e8ab25 (patch)
tree201f87728bf0a319239c42838e08178be87673c6 /dev-lisp/clisp
parentbump, should fix bug 257348 and bug 267784 (diff)
downloadgentoo-2-b7ce18d399cb9714aca7ab0c769cf18fe1e8ab25.tar.gz
gentoo-2-b7ce18d399cb9714aca7ab0c769cf18fe1e8ab25.tar.bz2
gentoo-2-b7ce18d399cb9714aca7ab0c769cf18fe1e8ab25.zip
remove old versions
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog7
-rw-r--r--dev-lisp/clisp/clisp-2.43-r1.ebuild95
-rw-r--r--dev-lisp/clisp/clisp-2.44.1-r1.ebuild105
-rw-r--r--dev-lisp/clisp/clisp-2.44.1.ebuild102
-rw-r--r--dev-lisp/clisp/clisp-2.46.ebuild130
-rw-r--r--dev-lisp/clisp/clisp-2.47.ebuild130
6 files changed, 6 insertions, 563 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 504d68875a64..7316e073f733 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/clisp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.93 2009/07/29 11:29:44 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.94 2009/07/29 11:32:46 hkbst Exp $
+
+ 29 Jul 2009; Marijn Schouten <hkBst@gentoo.org> -clisp-2.43-r1.ebuild,
+ -clisp-2.44.1.ebuild, -clisp-2.44.1-r1.ebuild, -clisp-2.46.ebuild,
+ -clisp-2.47.ebuild:
+ remove old versions
*clisp-2.48 (29 Jul 2009)
diff --git a/dev-lisp/clisp/clisp-2.43-r1.ebuild b/dev-lisp/clisp/clisp-2.43-r1.ebuild
deleted file mode 100644
index 034dfb6c59f8..000000000000
--- a/dev-lisp/clisp/clisp-2.43-r1.ebuild
+++ /dev/null
@@ -1,95 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.43-r1.ebuild,v 1.7 2008/09/02 22:32:13 opfer Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="amd64 ppc ~ppc64 -sparc x86"
-IUSE="X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
-
-RDEPEND="dev-lisp/gentoo-init
- >=dev-libs/libsigsegv-2.4
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- postgres? ( >=virtual/postgresql-server-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )"
-# * GNU gettext
-# + Not needed on systems with glibc 2.2 or newer, but recommended on all
-# other systems: needed if you want clisp with native language support.
-# sys-devel/gettext
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-src_compile() {
- CC="$(tc-getCC)"
-
- # built-in features
- local myconf="--with-dynamic-ffi"
- use readline || myconf="${myconf} --with-noreadline"
-
- # default modules
- enable_modules wildcard rawsock
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CC="${CC} -I $(pg_config --includedir)"
- fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- ./makemake ${myconf} > Makefile
-# emake config.lisp
-# sed -i 's,"vi","nano",g' config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV}/clisp-link
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.44.1-r1.ebuild b/dev-lisp/clisp/clisp-2.44.1-r1.ebuild
deleted file mode 100644
index ec7d52d1fb25..000000000000
--- a/dev-lisp/clisp/clisp-2.44.1-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.44.1-r1.ebuild,v 1.3 2008/07/30 13:51:14 pchrist Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="hyperspec X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
-
-RDEPEND="dev-lisp/gentoo-init
- virtual/libiconv
- >=dev-libs/libsigsegv-2.4
- >=dev-libs/ffcall-1.10
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- postgres? ( >=virtual/postgresql-server-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )
- hyperspec? ( dev-lisp/hyperspec )"
-# * GNU gettext
-# + Not needed on systems with glibc 2.2 or newer, but recommended on all
-# other systems: needed if you want clisp with native language support.
-# sys-devel/gettext
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-src_compile() {
- # built-in features
- local myconf="--with-ffcall"
- use readline || myconf="${myconf} --with-noreadline"
-
- # default modules
- enable_modules wildcard rawsock
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CPPFLAGS="-I $(pg_config --includedir)"
- fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- sed -i 's,"vi","nano",g' config.lisp
- if use hyperspec; then
- CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
- else
- CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
- fi
- sed -i "s,http://www.lisp.org/HyperSpec/,${CLHSROOT},g" config.lisp
- IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
- sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV}/clisp-link
- # stripping them removes common symbols (defined but unitialised variables)
- # which are then needed to build modules...
- export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.44.1.ebuild b/dev-lisp/clisp/clisp-2.44.1.ebuild
deleted file mode 100644
index 742ed625cecf..000000000000
--- a/dev-lisp/clisp/clisp-2.44.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.44.1.ebuild,v 1.3 2008/07/30 13:51:14 pchrist Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="2"
-KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE="hyperspec X new-clx fastcgi gdbm gtk pcre postgres readline svm zlib"
-
-RDEPEND="dev-lisp/gentoo-init
- virtual/libiconv
- >=dev-libs/libsigsegv-2.4
- >=dev-libs/ffcall-1.10
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- postgres? ( >=virtual/postgresql-server-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )
- hyperspec? ( dev-lisp/hyperspec )"
-# * GNU gettext
-# + Not needed on systems with glibc 2.2 or newer, but recommended on all
-# other systems: needed if you want clisp with native language support.
-# sys-devel/gettext
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PROVIDE="virtual/commonlisp"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-src_compile() {
- # built-in features
- local myconf="--with-ffcall"
- use readline || myconf="${myconf} --with-noreadline"
-
- # default modules
- enable_modules wildcard rawsock
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CPPFLAGS="-I $(pg_config --includedir)"
- fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- sed -i 's,"vi","nano",g' config.lisp
- if use hyperspec; then
- CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
- else
- CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
- fi
- sed -i "s,http://www.lisp.org/HyperSpec/,${CLHSROOT},g" config.lisp
- IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
- sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV}/clisp-link
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.46.ebuild b/dev-lisp/clisp/clisp-2.46.ebuild
deleted file mode 100644
index db2a37bc0a8d..000000000000
--- a/dev-lisp/clisp/clisp-2.46.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.46.ebuild,v 1.4 2008/07/30 13:51:14 pchrist Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-LICENSE="GPL-2"
-
-# EAPI="1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc -sparc ~x86"
-IUSE="hyperspec X new-clx fastcgi gdbm gtk pari pcre postgres readline svm zlib"
-
-RDEPEND="virtual/libiconv
- >=dev-libs/libsigsegv-2.4
- >=dev-libs/ffcall-1.10
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- pari? ( >=sci-mathematics/pari-2.3.0 )
- postgres? ( >=virtual/postgresql-server-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )
- hyperspec? ( dev-lisp/hyperspec )"
-# berkdb? ( sys-libs/db:4.5 )
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PDEPEND="dev-lisp/gentoo-init"
-
-PROVIDE="virtual/commonlisp"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-# modules not enabled:
-# * berkdb: must figure out a way to make the configure script pick up the
-# currect version of the library and headers
-# * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
-# * matlab, netica: not in portage
-# * oracle: can't install oracle-instantclient
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # More than -O1 breaks alpha/ia64
- use alpha || use ia64 && sed -i -e 's/-O2//g' src/makemake.in
-}
-
-src_compile() {
- # built-in features
- local myconf="--with-ffcall --with-dynamic-modules"
- use readline || myconf="${myconf} --with-noreadline"
-
- # We need this to build on alpha/ia64
- if use alpha || use ia64; then
- replace-flags -O? -O1
- append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
- fi
- # default modules
- enable_modules wildcard rawsock
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CPPFLAGS="-I $(pg_config --includedir)"
- fi
-# if use berkdb; then
-# enable_modules berkley-db
-# CPPFLAGS="${CPPFLAGS} -I /usr/include/db4.5"
-# fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pari && enable_modules pari
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- if use hyperspec; then
- CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
- else
- CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
- fi
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- sed -i 's,"vi","nano",g' config.lisp
- IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
- sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link
- # stripping them removes common symbols (defined but unitialised variables)
- # which are then needed to build modules...
- export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/clisp-2.47.ebuild b/dev-lisp/clisp/clisp-2.47.ebuild
deleted file mode 100644
index 68d373085ec9..000000000000
--- a/dev-lisp/clisp/clisp-2.47.ebuild
+++ /dev/null
@@ -1,130 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.47.ebuild,v 1.2 2009/01/05 21:44:03 maekke Exp $
-
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-LICENSE="GPL-2"
-
-# EAPI="1"
-SLOT="2"
-KEYWORDS="~alpha amd64 ~ia64 ~ppc -sparc x86"
-IUSE="hyperspec X new-clx fastcgi gdbm gtk pari pcre postgres readline svm zlib"
-
-RDEPEND="virtual/libiconv
- >=dev-libs/libsigsegv-2.4
- >=dev-libs/ffcall-1.10
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
- pari? ( >=sci-mathematics/pari-2.3.0 )
- postgres? ( >=virtual/postgresql-server-8.0 )
- readline? ( sys-libs/readline )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )
- hyperspec? ( dev-lisp/hyperspec )"
-# berkdb? ( sys-libs/db:4.5 )
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PDEPEND="dev-lisp/gentoo-init"
-
-PROVIDE="virtual/commonlisp"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-# modules not enabled:
-# * berkdb: must figure out a way to make the configure script pick up the
-# currect version of the library and headers
-# * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
-# * matlab, netica: not in portage
-# * oracle: can't install oracle-instantclient
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # More than -O1 breaks alpha/ia64
- use alpha || use ia64 && sed -i -e 's/-O2//g' src/makemake.in
-}
-
-src_compile() {
- # built-in features
- local myconf="--with-ffcall --with-dynamic-modules"
- use readline || myconf="${myconf} --with-noreadline"
-
- # We need this to build on alpha/ia64
- if use alpha || use ia64; then
- replace-flags -O? -O1
- append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
- fi
- # default modules
- enable_modules wildcard rawsock
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CPPFLAGS="-I $(pg_config --includedir)"
- fi
-# if use berkdb; then
-# enable_modules berkley-db
-# CPPFLAGS="${CPPFLAGS} -I /usr/include/db4.5"
-# fi
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pari && enable_modules pari
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- if use hyperspec; then
- CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
- else
- CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
- fi
-
- # configure chokes on --infodir option
- ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR} || die "./configure failed"
- cd ${BUILDDIR}
- sed -i 's,"vi","nano",g' config.lisp
- IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
- sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link
- # stripping them removes common symbols (defined but unitialised variables)
- # which are then needed to build modules...
- export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
- popd
- dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
- dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}