summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-02-13 19:52:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-02-13 19:52:59 +0000
commit4e2ed7115cf71182cd5d0bfd67e753745821195f (patch)
tree9aaacdc7ae5f7e3fa064c229d7cd3e0e08b1bfeb /dev-lisp/ecls/ecls-0.9h-r1.ebuild
parentUpdated RDEPS (diff)
downloadgentoo-2-4e2ed7115cf71182cd5d0bfd67e753745821195f.tar.gz
gentoo-2-4e2ed7115cf71182cd5d0bfd67e753745821195f.tar.bz2
gentoo-2-4e2ed7115cf71182cd5d0bfd67e753745821195f.zip
Modular X dependencies; Remove dependencies on X server/client -- X support in ECL is CLX and this is self-contained; Initial work toward supporting --with-cxx via c++ USE flag, see Bug #122236.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-lisp/ecls/ecls-0.9h-r1.ebuild')
-rw-r--r--dev-lisp/ecls/ecls-0.9h-r1.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-lisp/ecls/ecls-0.9h-r1.ebuild b/dev-lisp/ecls/ecls-0.9h-r1.ebuild
new file mode 100644
index 000000000000..5360c894c9a7
--- /dev/null
+++ b/dev-lisp/ecls/ecls-0.9h-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-0.9h-r1.ebuild,v 1.1 2006/02/13 19:52:59 mkennedy Exp $
+
+inherit eutils
+
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
+SRC_URI="mirror://sourceforge/ecls/ecl-${PV}.tgz"
+HOMEPAGE="http://ecls.sourceforge.net/"
+SLOT="0"
+LICENSE="BSD LGPL-2"
+# KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+KEYWORDS="-*" # Pending Bug #122236
+
+DEPEND="=dev-libs/gmp-4*
+ app-text/texi2html"
+
+# ECL fails to build with a system-installed Boehm GC (which apparently is a
+# rare configuration since most distributions neglect to install the useful
+# private headers). Until this is properly isolated, we use the Boehm GC
+# included with ECL.
+
+# dev-libs/boehm-gc
+
+IUSE="X c++"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/ecl-${PV:0:4}
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-headers-gentoo.patch || die
+}
+
+src_compile() {
+ local myconf="--with-system-gmp
+ --enable-boehm=included
+ --with-tcp
+ --with-ffi
+ --with-clos-streams
+ --with-cmuformat
+ --with-asdf
+ `use_with c++ cxx`
+ `use_with X x`
+ `use_with X clx`"
+ einfo "Configuring with: $myconf"
+ econf ${myconf} || die
+ make || die
+}
+
+src_install () {
+ make bindir=${D}/usr/bin \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ libdir=${D}/usr/lib/ecl \
+ docdir=${D}/usr/share/doc/${PF} install || true
+ dohtml doc/*.html
+ dodoc ANNOUNCEMENT Copyright LGPL
+
+ insinto /usr/share/doc/${PF}/
+ doins ${FILESDIR}/{clc-lite.lisp,README.Gentoo}
+}