summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-10 16:36:11 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-10 16:36:11 +0000
commit529b8e020ab3505a953b64e5160e46dd11a78e52 (patch)
tree8d9d63fd351d7b7debfdd48659357090f10ab395 /dev-lisp/xlispstat
parentMove conditional append-cflags out of global scope. (diff)
downloadgentoo-2-529b8e020ab3505a953b64e5160e46dd11a78e52.tar.gz
gentoo-2-529b8e020ab3505a953b64e5160e46dd11a78e52.tar.bz2
gentoo-2-529b8e020ab3505a953b64e5160e46dd11a78e52.zip
Fix building with GCC 4.4+ wrt #277422.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp/xlispstat')
-rw-r--r--dev-lisp/xlispstat/ChangeLog8
-rw-r--r--dev-lisp/xlispstat/files/xlispstat-3.52.20-fmax.patch23
-rw-r--r--dev-lisp/xlispstat/xlispstat-3.52.20.ebuild19
3 files changed, 44 insertions, 6 deletions
diff --git a/dev-lisp/xlispstat/ChangeLog b/dev-lisp/xlispstat/ChangeLog
index 5ed7398111b5..9c50221868aa 100644
--- a/dev-lisp/xlispstat/ChangeLog
+++ b/dev-lisp/xlispstat/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/xlispstat
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/xlispstat/ChangeLog,v 1.4 2007/07/22 08:00:34 graaff Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/xlispstat/ChangeLog,v 1.5 2009/08/10 16:36:11 ssuominen Exp $
+
+ 10 Aug 2009; Samuli Suominen <ssuominen@gentoo.org>
+ xlispstat-3.52.20.ebuild, +files/xlispstat-3.52.20-fmax.patch:
+ Fix building with GCC 4.4+ wrt #277422.
22 Jul 2007; Hans de Graaff <graaff@gentoo.org> xlispstat-3.52.20.ebuild:
Drop virtual/x11 references.
diff --git a/dev-lisp/xlispstat/files/xlispstat-3.52.20-fmax.patch b/dev-lisp/xlispstat/files/xlispstat-3.52.20-fmax.patch
new file mode 100644
index 000000000000..50ff409b663e
--- /dev/null
+++ b/dev-lisp/xlispstat/files/xlispstat-3.52.20-fmax.patch
@@ -0,0 +1,23 @@
+Source: DragonFlyBSD
+
+diff -ur xlispstat-3-52-20.orig/lowess.c xlispstat-3-52-20/lowess.c
+--- xlispstat-3-52-20.orig/lowess.c 2000-11-25 01:17:38.000000000 +0200
++++ xlispstat-3-52-20/lowess.c 2009-08-10 19:34:54.000000000 +0300
+@@ -12,7 +12,7 @@
+ /* forward declarations */
+ static double pow2 P1H(double);
+ static double pow3 P1H(double x);
+-static double fmax P2H(double, double);
++/* static double fmax P2H(double, double); */
+ static VOID sort P2H(double *, int);
+ static VOID lowest P11H(double *, double *, int, double, double *,
+ int, int, double *, int, double *, int *);
+@@ -20,7 +20,7 @@
+
+ static double pow2 P1C(double, x) { return(x * x); }
+ static double pow3 P1C(double, x) { return(x * x * x); }
+-static double fmax P2C(double, x, double, y) { return (x > y ? x : y); }
++/* static double fmax P2C(double, x, double, y) { return (x > y ? x : y); } */
+
+ int lowess P9C(double *, x, double *, y, int, n, double, f, int, nsteps, double, delta,
+ double *, ys, double *, rw, double *, res)
diff --git a/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild b/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild
index d1a4bee82aa4..15081bca4a5a 100644
--- a/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild
+++ b/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild
@@ -1,18 +1,29 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild,v 1.4 2007/07/22 08:00:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/xlispstat/xlispstat-3.52.20.ebuild,v 1.5 2009/08/10 16:36:11 ssuominen Exp $
+
+inherit eutils
DESCRIPTION="XLISP-STAT is a statistical environment based on a dialect of the Lisp language called XLISP."
HOMEPAGE="http://www.stat.uiowa.edu/~luke/xls/xlsinfo/xlsinfo.html"
SRC_URI="ftp://ftp.stat.umn.edu/pub/xlispstat/current/xlispstat-${PV//./-}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE="X"
-DEPEND="X? ( x11-libs/libX11 )"
+
+RDEPEND="X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}"
S=${WORKDIR}/${P//./-}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fmax.patch
+}
+
src_compile() {
local opts=''
use X && opts='--with-x' || opts='--without-x'