summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2007-03-03 23:36:25 +0000
committerMarius Mauch <genone@gentoo.org>2007-03-03 23:36:25 +0000
commit32921bfd3f5be0a94b9c8cd6fd4fd6c7eccf9e3c (patch)
tree33d9a49b2289fd8311b608eb406a8b45867ae3bb /dev-lisp
parentReplacing einfo with elog (diff)
downloadgentoo-2-32921bfd3f5be0a94b9c8cd6fd4fd6c7eccf9e3c.tar.gz
gentoo-2-32921bfd3f5be0a94b9c8cd6fd4fd6c7eccf9e3c.tar.bz2
gentoo-2-32921bfd3f5be0a94b9c8cd6fd4fd6c7eccf9e3c.zip
Replacing einfo with elog
(Portage version: 2.1.2-r10)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog7
-rw-r--r--dev-lisp/sbcl/sbcl-0.9.17.ebuild18
-rw-r--r--dev-lisp/sbcl/sbcl-0.9.18.ebuild18
-rw-r--r--dev-lisp/sbcl/sbcl-0.9.3.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-0.9.4.ebuild6
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.1.ebuild16
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.ebuild18
7 files changed, 47 insertions, 42 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index ab87b744d6e8..9aefb2006420 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.99 2007/01/18 04:09:58 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.100 2007/03/03 23:36:25 genone Exp $
+
+ 03 Mar 2007; Marius Mauch <genone@gentoo.org> sbcl-0.9.3.ebuild,
+ sbcl-0.9.4.ebuild, sbcl-0.9.17.ebuild, sbcl-0.9.18.ebuild,
+ sbcl-1.0.ebuild, sbcl-1.0.1.ebuild:
+ Replacing einfo with elog
*sbcl-1.0.1 (18 Jan 2007)
diff --git a/dev-lisp/sbcl/sbcl-0.9.17.ebuild b/dev-lisp/sbcl/sbcl-0.9.17.ebuild
index f89986a74833..5477cabc9bac 100644
--- a/dev-lisp/sbcl/sbcl-0.9.17.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.9.17.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.17.ebuild,v 1.1 2006/09/30 04:56:25 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.17.ebuild,v 1.2 2007/03/03 23:36:25 genone Exp $
inherit common-lisp-common-2 eutils flag-o-matic
@@ -36,19 +36,19 @@ PROVIDE="virtual/commonlisp"
MY_WORK=${WORKDIR}/files
-sbcl_einfo() {
+sbcl_elog() {
local method
case $# in
- 0) method=einfo;;
+ 0) method=elog;;
1) method=$1;;
- *) die "Invalid number of arguments to scbl_einfo"
+ *) die "Invalid number of arguments to scbl_elog"
esac
$method ""; while read line; do $method "${line}"; done; $method ""
}
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c |grep -qv vanilla; then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
So-called "hardened" compiler features are incompatible with SBCL. You
must use gcc-config to select a profile with non-hardened features
(the "vanilla" profile) and "source /etc/profile" before continuing.
@@ -56,7 +56,7 @@ EOF
die
fi
if ! built_with_use sys-libs/glibc nptl && (use x86 || use amd64); then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
Building SBCL without NPTL support on at least x86 and amd64
architectures is not a supported configuration in Gentoo. Please
refer to Bug #119016 for more information.
@@ -64,7 +64,7 @@ EOF
die
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Building SBCL on PPC with LDB support is not a supported configuration
in Gentoo. Please refer to Bug #121830 for more information.
Continuing with LDB support disabled.
@@ -106,7 +106,7 @@ src_unpack() {
>>${S}/customize-target-features.lisp
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Excluding LDB support for ppc-macos or ppc.
EOF
else
diff --git a/dev-lisp/sbcl/sbcl-0.9.18.ebuild b/dev-lisp/sbcl/sbcl-0.9.18.ebuild
index 041d3d578001..6dc0d09b590b 100644
--- a/dev-lisp/sbcl/sbcl-0.9.18.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.9.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.18.ebuild,v 1.3 2007/01/29 01:59:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.18.ebuild,v 1.4 2007/03/03 23:36:25 genone Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -33,19 +33,19 @@ DEPEND=">=dev-lisp/cl-asdf-1.84
PROVIDE="virtual/commonlisp"
-sbcl_einfo() {
+sbcl_elog() {
local method
case $# in
- 0) method=einfo;;
+ 0) method=elog;;
1) method=$1;;
- *) die "Invalid number of arguments to scbl_einfo"
+ *) die "Invalid number of arguments to scbl_elog"
esac
$method ""; while read line; do $method "${line}"; done; $method ""
}
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c |grep -qv vanilla; then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
So-called "hardened" compiler features are incompatible with SBCL. You
must use gcc-config to select a profile with non-hardened features
(the "vanilla" profile) and "source /etc/profile" before continuing.
@@ -53,7 +53,7 @@ EOF
die
fi
if ! built_with_use sys-libs/glibc nptl && (use x86 || use amd64); then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
Building SBCL without NPTL support on at least x86 and amd64
architectures is not a supported configuration in Gentoo. Please
refer to Bug #119016 for more information.
@@ -61,7 +61,7 @@ EOF
die
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Building SBCL on PPC with LDB support is not a supported configuration
in Gentoo. Please refer to Bug #121830 for more information.
Continuing with LDB support disabled.
@@ -102,7 +102,7 @@ EOF
>>${S}/customize-target-features.lisp
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Excluding LDB support for ppc-macos or ppc.
EOF
else
diff --git a/dev-lisp/sbcl/sbcl-0.9.3.ebuild b/dev-lisp/sbcl/sbcl-0.9.3.ebuild
index 5b44d8fbe7f1..e6828ff90c5f 100644
--- a/dev-lisp/sbcl/sbcl-0.9.3.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.9.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.3.ebuild,v 1.5 2005/12/02 02:51:57 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.3.ebuild,v 1.6 2007/03/03 23:36:25 genone Exp $
inherit common-lisp-common-2 eutils
@@ -36,7 +36,7 @@ MY_WORK=${S}/my_work
pkg_setup() {
if use hardened && gcc-config -c |grep -qv vanilla; then
- while read line; do einfo "${line}"; done <<'EOF'
+ while read line; do elog "${line}"; done <<'EOF'
So-called "hardened" compiler features are incompatible with SBCL. You
must use gcc-config to select a profile with non-hardened features
diff --git a/dev-lisp/sbcl/sbcl-0.9.4.ebuild b/dev-lisp/sbcl/sbcl-0.9.4.ebuild
index 633c028550ba..2cb56928dea6 100644
--- a/dev-lisp/sbcl/sbcl-0.9.4.ebuild
+++ b/dev-lisp/sbcl/sbcl-0.9.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.4.ebuild,v 1.3 2005/09/21 17:23:15 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-0.9.4.ebuild,v 1.4 2007/03/03 23:36:25 genone Exp $
inherit common-lisp-common-2 eutils
@@ -36,7 +36,7 @@ MY_WORK=${S}/my_work
pkg_setup() {
if use hardened && gcc-config -c |grep -qv vanilla; then
- while read line; do einfo "${line}"; done <<'EOF'
+ while read line; do elog "${line}"; done <<'EOF'
So-called "hardened" compiler features are incompatible with SBCL. You
must use gcc-config to select a profile with non-hardened features
diff --git a/dev-lisp/sbcl/sbcl-1.0.1.ebuild b/dev-lisp/sbcl/sbcl-1.0.1.ebuild
index 5af820c2f1f3..34b5b438b5c3 100644
--- a/dev-lisp/sbcl/sbcl-1.0.1.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.1.ebuild,v 1.2 2007/01/29 01:59:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.1.ebuild,v 1.3 2007/03/03 23:36:25 genone Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -32,19 +32,19 @@ DEPEND="doc? ( sys-apps/texinfo )"
PROVIDE="virtual/commonlisp"
-sbcl_einfo() {
+sbcl_elog() {
local method
case $# in
- 0) method=einfo;;
+ 0) method=elog;;
1) method=$1;;
- *) die "Invalid number of arguments to scbl_einfo"
+ *) die "Invalid number of arguments to scbl_elog"
esac
$method ""; while read line; do $method "${line}"; done; $method ""
}
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c |grep -qv vanilla; then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
So-called "hardened" compiler features are incompatible with SBCL. You
must use gcc-config to select a profile with non-hardened features
(the "vanilla" profile) and "source /etc/profile" before continuing.
@@ -52,7 +52,7 @@ EOF
die
fi
if ! built_with_use sys-libs/glibc nptl && (use x86 || use amd64); then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
Building SBCL without NPTL support on at least x86 and amd64
architectures is not a supported configuration in Gentoo. Please
refer to Bug #119016 for more information.
@@ -60,7 +60,7 @@ EOF
die
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Building SBCL on PPC with LDB support is not a supported configuration
in Gentoo. Please refer to Bug #121830 for more information.
Continuing with LDB support disabled.
@@ -101,7 +101,7 @@ EOF
>>${S}/customize-target-features.lisp
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Excluding LDB support for ppc-macos or ppc.
EOF
else
diff --git a/dev-lisp/sbcl/sbcl-1.0.ebuild b/dev-lisp/sbcl/sbcl-1.0.ebuild
index 265a33eecd7c..03e8d81f2b68 100644
--- a/dev-lisp/sbcl/sbcl-1.0.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.ebuild,v 1.3 2007/01/29 01:59:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.ebuild,v 1.4 2007/03/03 23:36:25 genone Exp $
inherit common-lisp-common-3 eutils flag-o-matic
@@ -32,19 +32,19 @@ DEPEND="doc? ( sys-apps/texinfo )"
PROVIDE="virtual/commonlisp"
-sbcl_einfo() {
+sbcl_elog() {
local method
case $# in
- 0) method=einfo;;
+ 0) method=elog;;
1) method=$1;;
- *) die "Invalid number of arguments to scbl_einfo"
+ *) die "Invalid number of arguments to scbl_elog"
esac
$method ""; while read line; do $method "${line}"; done; $method ""
}
pkg_setup() {
if built_with_use sys-devel/gcc hardened && gcc-config -c |grep -qv vanilla; then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
So-called "hardened" compiler features are incompatible with SBCL. You
must use gcc-config to select a profile with non-hardened features
(the "vanilla" profile) and "source /etc/profile" before continuing.
@@ -52,7 +52,7 @@ EOF
die
fi
if ! built_with_use sys-libs/glibc nptl && (use x86 || use amd64); then
- sbcl_einfo eerror <<'EOF'
+ sbcl_elog eerror <<'EOF'
Building SBCL without NPTL support on at least x86 and amd64
architectures is not a supported configuration in Gentoo. Please
refer to Bug #119016 for more information.
@@ -60,7 +60,7 @@ EOF
die
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Building SBCL on PPC with LDB support is not a supported configuration
in Gentoo. Please refer to Bug #121830 for more information.
Continuing with LDB support disabled.
@@ -101,7 +101,7 @@ EOF
>>${S}/customize-target-features.lisp
fi
if (use ppc-macos || use ppc) && use ldb; then
- sbcl_einfo ewarn <<'EOF'
+ sbcl_elog ewarn <<'EOF'
Excluding LDB support for ppc-macos or ppc.
EOF
else