summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-03-07 23:00:23 +0000
committerUlrich Müller <ulm@gentoo.org>2011-03-07 23:00:23 +0000
commit440dc81e478e63de5e0540753f9867516aede835 (patch)
tree37707c3686d5991c23524165364fc229e003788c /dev-lisp
parentGo back to EAPI=3 on user request (diff)
downloadgentoo-2-440dc81e478e63de5e0540753f9867516aede835.tar.gz
gentoo-2-440dc81e478e63de5e0540753f9867516aede835.tar.bz2
gentoo-2-440dc81e478e63de5e0540753f9867516aede835.zip
Avoid autodetection of the etags program. Make sure that with USE=emacs, etags from Emacs is used, fixes bug 357319.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls/ChangeLog7
-rw-r--r--dev-lisp/ecls/ecls-11.1.1-r1.ebuild17
2 files changed, 20 insertions, 4 deletions
diff --git a/dev-lisp/ecls/ChangeLog b/dev-lisp/ecls/ChangeLog
index 1f696224185e..dfe9d12c611c 100644
--- a/dev-lisp/ecls/ChangeLog
+++ b/dev-lisp/ecls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/ecls
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.39 2011/03/04 20:55:03 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ChangeLog,v 1.40 2011/03/07 23:00:23 ulm Exp $
+
+ 07 Mar 2011; Ulrich Mueller <ulm@gentoo.org> ecls-11.1.1-r1.ebuild:
+ Avoid autodetection of the etags program. Make sure that with USE=emacs,
+ etags from Emacs is used, fixes bug 357319. Thanks to François Bissey and
+ Steven Trogdon.
*ecls-11.1.1-r1 (04 Mar 2011)
diff --git a/dev-lisp/ecls/ecls-11.1.1-r1.ebuild b/dev-lisp/ecls/ecls-11.1.1-r1.ebuild
index 4be4d07e6606..294601ec9713 100644
--- a/dev-lisp/ecls/ecls-11.1.1-r1.ebuild
+++ b/dev-lisp/ecls/ecls-11.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-11.1.1-r1.ebuild,v 1.1 2011/03/04 20:55:03 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls/ecls-11.1.1-r1.ebuild,v 1.2 2011/03/07 23:00:23 ulm Exp $
EAPI=3
inherit eutils multilib
@@ -14,13 +14,14 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="BSD LGPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="debug gengc precisegc threads +unicode X"
+IUSE="debug emacs gengc precisegc threads +unicode X"
RDEPEND="dev-libs/gmp
virtual/libffi
>=dev-libs/boehm-gc-7.1[threads?]"
DEPEND="${RDEPEND}
- app-text/texi2html"
+ app-text/texi2html
+ emacs? ( virtual/emacs >=app-admin/eselect-emacs-1.12 )"
PDEPEND="dev-lisp/gentoo-init"
S="${WORKDIR}"/${MY_P}
@@ -55,6 +56,16 @@ src_configure() {
}
src_compile() {
+ if use emacs; then
+ local ETAGS=$(eselect --brief etags list | sed -ne '/emacs/{p;q}')
+ [[ -n ${ETAGS} ]] || die "No etags implementation found"
+ pushd build || die
+ emake ETAGS=${ETAGS} TAGS || die
+ popd
+ else
+ touch build/TAGS
+ fi
+
#parallel fails
emake -j1 || die "Compilation failed"
}