summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2014-09-14 09:57:58 +0000
committerAndrey Grozin <grozin@gentoo.org>2014-09-14 09:57:58 +0000
commit4fb751a2d60dd58b6637eae809e5571042bb0bbb (patch)
tree13dbda2ea49a179f832fc5ee825ce54984bbd33c /dev-lisp
parentVersion bump. Bug #511094 (diff)
downloadgentoo-2-4fb751a2d60dd58b6637eae809e5571042bb0bbb.tar.gz
gentoo-2-4fb751a2d60dd58b6637eae809e5571042bb0bbb.tar.bz2
gentoo-2-4fb751a2d60dd58b6637eae809e5571042bb0bbb.zip
Version bump
(Portage version: 2.2.12/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clozurecl/ChangeLog10
-rw-r--r--dev-lisp/clozurecl/clozurecl-1.10.ebuild (renamed from dev-lisp/clozurecl/clozurecl-1.8.ebuild)30
2 files changed, 28 insertions, 12 deletions
diff --git a/dev-lisp/clozurecl/ChangeLog b/dev-lisp/clozurecl/ChangeLog
index 80d21996b242..64af842ed728 100644
--- a/dev-lisp/clozurecl/ChangeLog
+++ b/dev-lisp/clozurecl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/clozurecl
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.12 2013/10/14 10:48:32 grozin Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/ChangeLog,v 1.13 2014/09/14 09:57:58 grozin Exp $
+
+*clozurecl-1.10 (14 Sep 2014)
+
+ 14 Sep 2014; Andrey Grozin <grozin@gentoo.org> -clozurecl-1.8.ebuild,
+ +clozurecl-1.10.ebuild:
+ Version bump
*clozurecl-1.9_p1-r1 (14 Oct 2013)
diff --git a/dev-lisp/clozurecl/clozurecl-1.8.ebuild b/dev-lisp/clozurecl/clozurecl-1.10.ebuild
index b510406f4364..1fc324f01120 100644
--- a/dev-lisp/clozurecl/clozurecl-1.8.ebuild
+++ b/dev-lisp/clozurecl/clozurecl-1.10.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.8.ebuild,v 1.2 2012/06/07 17:31:50 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clozurecl/clozurecl-1.10.ebuild,v 1.1 2014/09/14 09:57:58 grozin Exp $
-EAPI=3
-inherit eutils multilib
+EAPI=5
+inherit eutils multilib toolchain-funcs
MY_PN=ccl
MY_P=${MY_PN}-${PV}
@@ -21,7 +21,9 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc"
-DEPEND="!dev-lisp/openmcl"
+RDEPEND=">=dev-lisp/asdf-2.33-r3:="
+DEPEND="${RDEPEND}
+ !dev-lisp/openmcl"
S="${WORKDIR}"/${MY_PN}
@@ -29,17 +31,24 @@ ENVD="${T}"/50ccl
src_configure() {
if use x86; then
- CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers
+ CCL_RUNTIME=lx86cl; CCL_HEADERS=x86-headers; CCL_KERNEL=linuxx8632
elif use amd64; then
- CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64
+ CCL_RUNTIME=lx86cl64; CCL_HEADERS=x86-headers64; CCL_KERNEL=linuxx8664
elif use ppc; then
- CCL_RUNTIME=ppccl; CCL_HEADERS=headers
+ CCL_RUNTIME=ppccl; CCL_HEADERS=headers; CCL_KERNEL=linuxppc
elif use ppc64; then
- CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64
+ CCL_RUNTIME=ppccl64; CCL_HEADERS=headers64; CCL_KERNEL=linuxppc64
fi
}
+src_prepare() {
+ cp /usr/share/common-lisp/source/asdf/build/asdf.lisp tools/ || die
+}
+
src_compile() {
+ emake -C lisp-kernel/${CCL_KERNEL} clean
+ emake -C lisp-kernel/${CCL_KERNEL} all CC="$(tc-getCC)"
+
unset CCL_DEFAULT_DIRECTORY
./${CCL_RUNTIME} -n -b -Q -e '(ccl:rebuild-ccl :full t)' -e '(ccl:quit)' || die "Compilation failed"
@@ -65,8 +74,9 @@ src_install() {
# until we figure out which source files are necessary for runtime
# optional features and which aren't, we install all sources
find . -type f -name '*fsl' -delete
+ rm -f lisp-kernel/${CCL_KERNEL}/*.o
cp -a compiler level-0 level-1 lib library \
- lisp-kernel scripts tools xdump \
+ lisp-kernel scripts tools xdump contrib \
"${D}"/${install_dir} || die
cp -a ${CCL_HEADERS} "${D}"/${install_dir} || die