summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPanagiotis Christopoulos <pchrist@gentoo.org>2010-03-26 01:03:35 +0000
committerPanagiotis Christopoulos <pchrist@gentoo.org>2010-03-26 01:03:35 +0000
commit6675a9e05673fdd5f6dec06f1c8da9848160edcf (patch)
tree08e073e9742b49de0d5cb377c9193c744a0a53c9 /dev-lisp
parentRemoved sys-devel/gdb-7.1 from masking on hardened profile (diff)
downloadgentoo-2-6675a9e05673fdd5f6dec06f1c8da9848160edcf.tar.gz
gentoo-2-6675a9e05673fdd5f6dec06f1c8da9848160edcf.tar.bz2
gentoo-2-6675a9e05673fdd5f6dec06f1c8da9848160edcf.zip
Fallback to EAPI=2 and reenable the old BIG FAT timestamp hack, until EAPI=3 is available to all testing versions of portage
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog7
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild16
2 files changed, 19 insertions, 4 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 86c11c879e6f..c938d7200777 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.164 2010/03/25 23:48:58 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.165 2010/03/26 01:03:35 pchrist Exp $
+
+ 26 Mar 2010; Panagiotis Christopoulos <pchrist@gentoo.org>
+ sbcl-1.0.36-r1.ebuild:
+ Fallback to EAPI=2 and reenable the old BIG FAT timestamp hack, until
+ EAPI=3 is available to all testing versions of portage
*sbcl-1.0.36-r1 (25 Mar 2010)
diff --git a/dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild b/dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild
index 9651b9aba0b6..e2325d7706f1 100644
--- a/dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild,v 1.1 2010/03/25 23:48:58 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.36-r1.ebuild,v 1.2 2010/03/26 01:03:35 pchrist Exp $
-EAPI=3
+EAPI=2
-inherit multilib eutils
+inherit multilib eutils common-lisp-common-3
#same order as http://www.sbcl.org/platform-table.html
BV_X86=1.0.36
@@ -185,4 +185,14 @@ EOF
echo "SBCL_HOME=/usr/$(get_libdir)/${PN}" > "${ENVD}"
echo "SBCL_SOURCE_ROOT=/usr/$(get_libdir)/${PN}/src" >> "${ENVD}"
doenvd "${ENVD}"
+
+ impl-save-timestamp-hack sbcl || die
+}
+
+pkg_postinst() {
+ standard-impl-postinst sbcl
+}
+
+pkg_postrm() {
+ standard-impl-postrm sbcl /usr/bin/sbcl
}