summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2007-10-17 12:29:14 +0000
committerMarijn Schouten <hkbst@gentoo.org>2007-10-17 12:29:14 +0000
commitb6325e98eb05b5ea069ef6284de2d0f53ab50ef5 (patch)
treeff094529fee087294b8b599050cac79c53310ea9 /dev-lisp
parentx11-libs/gtksourceview: Bump to version 2.0.1 (bugfix and translations) (diff)
downloadgentoo-2-b6325e98eb05b5ea069ef6284de2d0f53ab50ef5.tar.gz
gentoo-2-b6325e98eb05b5ea069ef6284de2d0f53ab50ef5.tar.bz2
gentoo-2-b6325e98eb05b5ea069ef6284de2d0f53ab50ef5.zip
bump
(Portage version: 2.1.3.13)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog76
-rw-r--r--dev-lisp/clisp/clisp-2.42.ebuild76
-rw-r--r--dev-lisp/clisp/files/digest-clisp-2.423
3 files changed, 153 insertions, 2 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index e854758c1ded..6dde6d540965 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,7 +1,79 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.63 2007/09/09 18:01:53 josejx Exp $
-
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.64 2007/10/17 12:29:14 hkbst Exp $
+
+*clisp-2.42 (17 Oct 2007)
+
+ 17 Oct 2007; Marijn Schouten <hkBst@gentoo.org> +clisp-2.42.ebuild:
+ bump
+User visible changes
+--------------------
+
+* New module gtk2 interfaces to GTK+ v2 and makes it possible to build
+ GUI with Glade.
+ Thanks to James Bailey <dgym.bailey@gmail.com> for the original code.
+ See <http://clisp.cons.org/impnotes/gtk.html> for details.
+
+* New module gdbm interfaces to GNU DataBase Manager.
+ Thanks to Masayuki Onjo <masayuki.onjo@gmail.com>.
+ See <http://clisp.cons.org/impnotes/gdbm.html> for details.
+
+* A kind of Meta-Object Protocol for structures is now available.
+ See <http://clisp.cons.org/impnotes/defstruct-mop.html> for details.
+
+* Module libsvm has been upgraded to the upstream version 2.84.
+ See <http://clisp.cons.org/impnotes/libsvm.html> for details.
+
+* NEW-CLX module now supports Stumpwm <http://www.nongnu.org/stumpwm/>.
+ Thanks to Shawn Betts <sabetts@vcn.bc.ca>.
+ New NEW-CLX demos: bball bwindow greynetic hanoi petal plaid recurrence from
+ <http://www.cs.cmu.edu/afs/cs/project/ai-repository/ai/lang/lisp/gui/clx/clx_demo.cl>.
+ New NEW-CLX demo: clclock based on <http://common-lisp.net/~crhodes/clx>.
+ New function XLIB:OPEN-DEFAULT-DISPLAY from portable CLX.
+
+* Function EXT:ARGLIST now works on macros too.
+ See <http://clisp.cons.org/impnotes/flow-dict.html#arglist> for details.
+
+* Macro TRACE has a new option :BINDINGS, which is useful to share data
+ between PRE-* and POST-* forms.
+ See <http://clisp.cons.org/environment-dict.html#trace> for details.
+
+* Macro FFI:DEF-C-TYPE can now be called with one argument to define an
+ integer type.
+ See <http://clisp.cons.org/impnotes/dffi.html#def-c-type> for details.
+
+* New function EXT:RENAME-DIR can be used to rename directories.
+ See <http://clisp.cons.org/impnotes/file-dict.html#rename-dir> for details.
+
+* Functions FILE-LENGTH and FILE-POSITION now work on unbuffered streams too.
+ See <http://clisp.cons.org/impnotes/stream-dict.html#file-pos> for details.
+
+* Bug fixes:
+ + Fixed EXT:LETF to work with more than one place. [ 1731462 ]
+ + Fixed rounding of long floats [even+1/2]. [ 1589311 ]
+ + Fixed stdio when running without a TTY, e.g., under SSH. [ 1592343 ]
+ + ANSI compliance: PPRINT dispatch is now respected for nested
+ objects, not just the top-level. [ 1483768, 1598053 ]
+ + Fixed print-read-consistency of strings containing #\Return characters
+ (manifested by COMPILE-FILE). [ 1578179 ]
+ + Fixed "clisp-link run". [ 1469663 ]
+ + Fixed ATANH branch cut continuity. [ 1436987 ]
+ + Reset the function lambda expression when loading a compiled file.
+ [ 1603260 ]
+ + DOCUMENTATION set by SETF is now preserved by COMPILE. [ 1604579 ]
+ + LISTEN now calls STREAM-LISTEN as per the Gray proposal. [ 1607666 ]
+ + IMPORT into the KEYWORD package does not make a symbol a constant
+ variable. [ 1612859 ]
+ + DEFPACKAGE code was executed during non top-level compilation. [ 1612313 ]
+ + Fixed format error message formatting. [ 1482465 ]
+ + Fixed *PPRINT-FIRST-NEWLINE* handling. [ 1412454 ]
+ + Improved hash code generation for very large bignums and for long lists.
+ [ 948868, 1208124 ]
+ + Some bugs related to UNICODE-16 & UNICODE-32. [ 1564818, 1631760, 1632718 ]
+ + All exported defined symbols are now properly locked. [ 1713130 ]
+ + Berkeley-DB module no longer fills up error log file. [ 1779416 ]
+ + New-clx now supports 64-bit KeySym. [ 1797132 ]
+
09 Sep 2007; Joseph Jezak <josejx@gentoo.org> clisp-2.41.ebuild:
Marked ppc stable for bug #173050.
diff --git a/dev-lisp/clisp/clisp-2.42.ebuild b/dev-lisp/clisp/clisp-2.42.ebuild
new file mode 100644
index 000000000000..b65e764af220
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.42.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.42.ebuild,v 1.1 2007/10/17 12:29:14 hkbst Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="X new-clx fastcgi pcre postgres readline zlib"
+
+RDEPEND=">=dev-libs/libsigsegv-2.4
+ virtual/tetex
+ fastcgi? ( dev-libs/fcgi )
+ postgres? ( >=dev-db/postgresql-8.0 )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( x11-libs/libXpm ) )"
+# * GNU gettext
+# + Not needed on systems with glibc 2.2 or newer, but recommended on all
+# other systems: needed if you want clisp with native language support.
+# sys-devel/gettext
+
+DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PROVIDE="virtual/commonlisp"
+
+BUILDDIR="builddir"
+
+src_compile() {
+ CC="$(tc-getCC)"
+ local myconf="--with-dynamic-ffi --with-module=wildcard --with-module=rawsock"
+ use elibc_glibc && myconf="${myconf} --with-module=bindings/glibc"
+ use readline || myconf="${myconf} --with-noreadline"
+ if use X; then
+ if use new-clx; then
+ myconf="${myconf} --with-module=clx/new-clx"
+ else
+ myconf="${myconf} --with-module=clx/mit-clx"
+ fi
+ fi
+ if use postgres; then
+ myconf="${myconf} --with-module=postgresql"
+ CC="${CC} -I $(pg_config --includedir)"
+ fi
+ use fastcgi && myconf="${myconf} --with-module=fastcgi"
+ use pcre && myconf="${myconf} --with-module=pcre"
+ use zlib && myconf="${myconf} --with-module=zlib"
+
+ # configure chokes on --infodir option
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ --hyperspec="http://www.lisp.org/HyperSpec/FrontMatter/" \
+ ${myconf} ${BUILDDIR} || die "./configure failed"
+ cd ${BUILDDIR}
+ ./makemake ${myconf} >Makefile
+ emake config.lisp
+ sed -i 's,"vi","nano",g' config.lisp
+ # parallel build fails
+ emake -j1|| die "emake failed"
+}
+
+src_install() {
+ pushd ${BUILDDIR}
+ make DESTDIR="${D}" prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ chmod a+x "${D}"/usr/$(get_libdir)/clisp/clisp-link
+ popd
+ dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
+ dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
+}
diff --git a/dev-lisp/clisp/files/digest-clisp-2.42 b/dev-lisp/clisp/files/digest-clisp-2.42
new file mode 100644
index 000000000000..0634b9bb6066
--- /dev/null
+++ b/dev-lisp/clisp/files/digest-clisp-2.42
@@ -0,0 +1,3 @@
+MD5 3fc28342e446a62c1eb4f65277929888 clisp-2.42.tar.bz2 8284453
+RMD160 b6d6b3c255c3f91f76e5fc46b1f05cca2ebbb388 clisp-2.42.tar.bz2 8284453
+SHA256 6e0f44fd76505557620b43d8b6cfdb3fcd6bfbe1facd7c1b951fc0e47fff30d8 clisp-2.42.tar.bz2 8284453