summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-03-11 16:51:39 +0000
commitc1254f995a7d0a3974f973d7355f666d8ff0857a (patch)
tree421fddbcc14f0db09b6583aeb89409860a43d92c /dev-lisp
parent- marking 2.1.3 stable for all supporting arches (diff)
downloadgentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.tar.gz
gentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.tar.bz2
gentoo-2-c1254f995a7d0a3974f973d7355f666d8ff0857a.zip
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/openmcl-build-tools/ChangeLog10
-rw-r--r--dev-lisp/openmcl-build-tools/Manifest2
-rw-r--r--dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-200405051
-rw-r--r--dev-lisp/openmcl-build-tools/metadata.xml15
-rw-r--r--dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild31
-rw-r--r--dev-lisp/openmcl/ChangeLog10
-rw-r--r--dev-lisp/openmcl/Manifest2
-rw-r--r--dev-lisp/openmcl/files/digest-openmcl-0.14.2_p11
-rw-r--r--dev-lisp/openmcl/metadata.xml12
-rw-r--r--dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild70
10 files changed, 154 insertions, 0 deletions
diff --git a/dev-lisp/openmcl-build-tools/ChangeLog b/dev-lisp/openmcl-build-tools/ChangeLog
new file mode 100644
index 000000000000..b99e89a1618b
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/openmcl-build-tools
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl-build-tools/ChangeLog,v 1.1 2005/03/11 16:51:04 mkennedy Exp $
+
+*openmcl-build-tools-20040505 (11 Mar 2005)
+
+ 11 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +openmcl-build-tools-20040505.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/openmcl-build-tools/Manifest b/dev-lisp/openmcl-build-tools/Manifest
new file mode 100644
index 000000000000..4a4c7b5f6f0e
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/Manifest
@@ -0,0 +1,2 @@
+MD5 408063b3dcedb652a5bbd9529da7779d openmcl-build-tools-20040505.ebuild 602
+MD5 cdc510f48391503558fabc7dbe45228f files/digest-openmcl-build-tools-20040505 83
diff --git a/dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-20040505 b/dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-20040505
new file mode 100644
index 000000000000..7063b43ee2d5
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/files/digest-openmcl-build-tools-20040505
@@ -0,0 +1 @@
+MD5 59543d8cb8e7c56366e1108ab35acb87 openmcl-build-tools_20040505-2.tar.gz 2723206
diff --git a/dev-lisp/openmcl-build-tools/metadata.xml b/dev-lisp/openmcl-build-tools/metadata.xml
new file mode 100644
index 000000000000..2183ba25a528
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+OpenMCL is a Common Lisp implementation. It began as a subset of the commercial
+MCL (Macintosh Common Lisp), and has grown into a full-featured, stable
+implementation. All of OpenMCL is released under the GNU Lesser General Public
+License. Commercial MCL does have a nicely integrated IDE and user interface
+libraries, which were not open-sourced and are not available in OpenMCL.
+
+This port contains the heap image and other tools for building OpenMCL (OpenMCL
+needs an OpenMCL heap image to build itself).
+</longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild b/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild
new file mode 100644
index 000000000000..7634e1bd64d2
--- /dev/null
+++ b/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl-build-tools/openmcl-build-tools-20040505.ebuild,v 1.1 2005/03/11 16:51:04 mkennedy Exp $
+
+inherit eutils common-lisp-common-2
+
+DEB_PV=2
+
+DESCRIPTION="OpenMCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://packages.debian.org/unstable/devel/openmcl-build-tools"
+SRC_URI="http://ftp.debian.org/debian/pool/main/o/${PN}/${PN}_${PV}-${DEB_PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ tar xfz ${S}/openmcl-interfaces-${PV:2}.tar.gz -C ${S} || die
+}
+
+src_install() {
+ insinto /usr/lib/openmcl
+ doins PPCCL-orig
+ doins -r ccl/headers
+ do-debian-credits
+}
diff --git a/dev-lisp/openmcl/ChangeLog b/dev-lisp/openmcl/ChangeLog
new file mode 100644
index 000000000000..7a4f39a27226
--- /dev/null
+++ b/dev-lisp/openmcl/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-lisp/openmcl
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl/ChangeLog,v 1.1 2005/03/11 16:51:39 mkennedy Exp $
+
+*openmcl-0.14.2_p1 (11 Mar 2005)
+
+ 11 Mar 2005; Matthew Kennedy <mkennedy@gentoo.org> +metadata.xml,
+ +openmcl-0.14.2_p1.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/dev-lisp/openmcl/Manifest b/dev-lisp/openmcl/Manifest
new file mode 100644
index 000000000000..91dda0b513c6
--- /dev/null
+++ b/dev-lisp/openmcl/Manifest
@@ -0,0 +1,2 @@
+MD5 5ae485bc9ea53f03aca27b2c501332fe openmcl-0.14.2_p1.ebuild 512
+MD5 0b1601a0fba77078c94cba935222f8cd files/digest-openmcl-0.14.2_p1 72
diff --git a/dev-lisp/openmcl/files/digest-openmcl-0.14.2_p1 b/dev-lisp/openmcl/files/digest-openmcl-0.14.2_p1
new file mode 100644
index 000000000000..378573b0b7a1
--- /dev/null
+++ b/dev-lisp/openmcl/files/digest-openmcl-0.14.2_p1
@@ -0,0 +1 @@
+MD5 8d4ef665b2d8cd15f989ed6102657016 openmcl_0.14.2.p1.o.tar.gz 2303796
diff --git a/dev-lisp/openmcl/metadata.xml b/dev-lisp/openmcl/metadata.xml
new file mode 100644
index 000000000000..daf6a52f4173
--- /dev/null
+++ b/dev-lisp/openmcl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+<longdescription>
+OpenMCL is a Common Lisp implementation. It began as a subset of the commercial
+MCL (Macintosh Common Lisp), and has grown into a full-featured, stable
+implementation. All of OpenMCL is released under the GNU Lesser General Public
+License. Commercial MCL does have a nicely integrated IDE and user interface
+libraries, which were not open-sourced and are not available in OpenMCL.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild b/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
new file mode 100644
index 000000000000..ae41b7572206
--- /dev/null
+++ b/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/openmcl/openmcl-0.14.2_p1.ebuild,v 1.1 2005/03/11 16:51:39 mkennedy Exp $
+
+inherit eutils common-lisp-common-2
+
+EXTRA_PV=o
+MY_PV=${PV/_p/.p}
+
+DESCRIPTION="OpenMCL is a Common Lisp implementation, derived from Digitool's MCL product"
+HOMEPAGE="http://openmcl.clozure.com/
+ http://packages.debian.org/unstable/devel/openmcl"
+SRC_URI="http://ftp.debian.org/debian/pool/main/o/${PN}/${PN}_${MY_PV}.${EXTRA_PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~ppc"
+IUSE=""
+
+DEPEND="=dev-lisp/common-lisp-controller-4*
+ >=dev-lisp/cl-asdf-1.84
+ dev-lisp/openmcl-build-tools"
+
+PROVIDE="virtual/commonlisp"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+# The following relies heavily on what I read in debian/rules...
+
+src_unpack() {
+ unpack ${A}
+ pushd ${S}
+ sed -e "s,%ver%,${MY_PV}.${EXTRA_PV}," \
+ < debian/run-bootstrap.lisp.template \
+ > debian/run-bootstrap.lisp
+ cp debian/Makefile .
+ cp -a /usr/lib/openmcl/{PPCCL-orig,headers} .
+ popd
+}
+
+src_compile() {
+ OPENMCL=/usr/bin/openmcl make || die
+}
+
+src_install() {
+ dodir /etc
+ dodir /usr/bin
+ dodir /usr/lib/common-lisp/bin
+ dodir /usr/lib/openmcl
+ dodir /usr/lib/openmcl/lib
+ dodir /usr/lib/openmcl/library
+ make install DESTDIR=${D} || die
+ insinto /usr/lib/openmcl
+ doins debian/install-clc.lisp
+ exeinto /usr/lib/common-lisp/bin/
+ doexe debian/openmcl.sh
+ dohtml doc/HTML/*.html
+ doman debian/openmcl.1
+ do-debian-credits
+}
+
+pkg_postinst() {
+ standard-impl-postinst openmcl || die
+}
+
+pkg_postrm() {
+ standard-impl-postrm openmcl /usr/bin/openmcl
+ if [ ! -x /usr/bin/openmcl ]; then
+ rm -rf /usr/lib/openmcl/ || die
+ fi
+}