summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-07-25 20:36:55 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-07-25 20:36:55 +0000
commitdaa4ac3b531c38a06e5f42cdd451ddced6cfb946 (patch)
treead2f829b997f01b8b3a7b6be1a7e9a970aaefdc7 /dev-lisp
parentNew release (diff)
downloadgentoo-2-daa4ac3b531c38a06e5f42cdd451ddced6cfb946.tar.gz
gentoo-2-daa4ac3b531c38a06e5f42cdd451ddced6cfb946.tar.bz2
gentoo-2-daa4ac3b531c38a06e5f42cdd451ddced6cfb946.zip
.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-gcc-xml-ffi/ChangeLog11
-rw-r--r--dev-lisp/cl-gcc-xml-ffi/Manifest4
-rw-r--r--dev-lisp/cl-gcc-xml-ffi/cl-gcc-xml-ffi-0.1.2.20050724.ebuild42
-rw-r--r--dev-lisp/cl-gcc-xml-ffi/files/0.1.2.20050724-fasl-output-gentoo.patch22
-rw-r--r--dev-lisp/cl-gcc-xml-ffi/files/digest-cl-gcc-xml-ffi-0.1.2.200507241
-rw-r--r--dev-lisp/cl-gcc-xml-ffi/metadata.xml5
6 files changed, 85 insertions, 0 deletions
diff --git a/dev-lisp/cl-gcc-xml-ffi/ChangeLog b/dev-lisp/cl-gcc-xml-ffi/ChangeLog
new file mode 100644
index 000000000000..389fd14295da
--- /dev/null
+++ b/dev-lisp/cl-gcc-xml-ffi/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-lisp/cl-gcc-xml-ffi
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-gcc-xml-ffi/ChangeLog,v 1.1 2005/07/25 20:36:55 mkennedy Exp $
+
+*cl-gcc-xml-ffi-0.1.2.20050724 (25 Jul 2005)
+
+ 25 Jul 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/0.1.2.20050724-fasl-output-gentoo.patch, +metadata.xml,
+ +cl-gcc-xml-ffi-0.1.2.20050724.ebuild:
+ Initial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>.
+
diff --git a/dev-lisp/cl-gcc-xml-ffi/Manifest b/dev-lisp/cl-gcc-xml-ffi/Manifest
new file mode 100644
index 000000000000..4afd3e717bbc
--- /dev/null
+++ b/dev-lisp/cl-gcc-xml-ffi/Manifest
@@ -0,0 +1,4 @@
+MD5 4c4f46446100b0c33aa130eed9ca099e cl-gcc-xml-ffi-0.1.2.20050724.ebuild 1191
+MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
+MD5 9ca6553abd673e617fbf39edbcad8e8a files/0.1.2.20050724-fasl-output-gentoo.patch 827
+MD5 8ddb4339caa081455ec0d3b5f6f7993d files/digest-cl-gcc-xml-ffi-0.1.2.20050724 77
diff --git a/dev-lisp/cl-gcc-xml-ffi/cl-gcc-xml-ffi-0.1.2.20050724.ebuild b/dev-lisp/cl-gcc-xml-ffi/cl-gcc-xml-ffi-0.1.2.20050724.ebuild
new file mode 100644
index 000000000000..f3b4afde66b8
--- /dev/null
+++ b/dev-lisp/cl-gcc-xml-ffi/cl-gcc-xml-ffi-0.1.2.20050724.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-gcc-xml-ffi/cl-gcc-xml-ffi-0.1.2.20050724.ebuild,v 1.1 2005/07/25 20:36:55 mkennedy Exp $
+
+inherit common-lisp
+
+MY_PN=${PN/cl-/}
+
+DESCRIPTION="Cyrus Harmon's Common Lisp GCC-XML FFI library."
+HOMEPAGE="http://www.cyrusharmon.org/cl/blog/"
+SRC_URI="http://cyrusharmon.org/cl/static/releases/${MY_PN}-${PV/.2005/-2005}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lisp/cl-ch-util
+ dev-lisp/cl-uffi
+ dev-lisp/cl-xmls
+ dev-cpp/gccxml"
+
+S=${WORKDIR}/${MY_PN}
+
+CLPACKAGE='gcc-xml-ffi gcc-xml-ffi-test'
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-fasl-output-gentoo.patch || die
+ rm ${S}/Makefile
+}
+
+src_install() {
+ dodir $CLSYSTEMROOT
+ insinto $CLSOURCEROOT/gcc-xml-ffi
+ doins *.asd
+ insinto $CLSOURCEROOT/gcc-xml-ffi/src/
+ doins src/*.cl
+ insinto $CLSOURCEROOT/gcc-xml-ffi/test/
+ doins test/*.cl
+ dosym ${CLSOURCEROOT}/gcc-xml-ffi/gcc-xml-ffi.asd ${CLSYSTEMROOT}/gcc-xml-ffi.asd
+ dosym ${CLSOURCEROOT}/gcc-xml-ffi/gcc-xml-ffi-test.asd ${CLSYSTEMROOT}/gcc-xml-ffi-test.asd
+ dodoc ChangeLog README
+}
diff --git a/dev-lisp/cl-gcc-xml-ffi/files/0.1.2.20050724-fasl-output-gentoo.patch b/dev-lisp/cl-gcc-xml-ffi/files/0.1.2.20050724-fasl-output-gentoo.patch
new file mode 100644
index 000000000000..a2ae0d57ecb9
--- /dev/null
+++ b/dev-lisp/cl-gcc-xml-ffi/files/0.1.2.20050724-fasl-output-gentoo.patch
@@ -0,0 +1,22 @@
+diff -ur gcc-xml-ffi.orig/gcc-xml-ffi.asd gcc-xml-ffi/gcc-xml-ffi.asd
+--- gcc-xml-ffi.orig/gcc-xml-ffi.asd 2005-07-24 13:44:50.000000000 -0500
++++ gcc-xml-ffi/gcc-xml-ffi.asd 2005-07-25 10:51:49.000000000 -0500
+@@ -12,18 +12,8 @@
+ ;;;;
+ (defclass gcc-xml-ffi-cl-source-file (cl-source-file) ())
+
+-(defparameter *fasl-directory*
+- (make-pathname :directory '(:relative
+- #+sbcl "sbcl-fasl"
+- #+openmcl "openmcl-fasl"
+- #-(or sbcl openmcl) "fasl")))
+-
+ (defmethod source-file-type ((c gcc-xml-ffi-cl-source-file) (s module)) "cl")
+
+-(defmethod asdf::output-files :around ((operation compile-op) (c gcc-xml-ffi-cl-source-file))
+- (list (merge-pathnames *fasl-directory* (compile-file-pathname (component-pathname c)))))
+-
+-
+ (defsystem :gcc-xml-ffi
+ :name "gcc-xml-ffi"
+ :author "Cyrus Harmon"
diff --git a/dev-lisp/cl-gcc-xml-ffi/files/digest-cl-gcc-xml-ffi-0.1.2.20050724 b/dev-lisp/cl-gcc-xml-ffi/files/digest-cl-gcc-xml-ffi-0.1.2.20050724
new file mode 100644
index 000000000000..92342314abec
--- /dev/null
+++ b/dev-lisp/cl-gcc-xml-ffi/files/digest-cl-gcc-xml-ffi-0.1.2.20050724
@@ -0,0 +1 @@
+MD5 b671fa0d8aa74bd77e02d53281fbe190 gcc-xml-ffi-0.1.2-20050724.tar.gz 10271
diff --git a/dev-lisp/cl-gcc-xml-ffi/metadata.xml b/dev-lisp/cl-gcc-xml-ffi/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-gcc-xml-ffi/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>