summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-11-05 23:12:31 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-11-05 23:12:31 +0000
commit0d1e8ce23f7114b9de794579bbc04a47a0391390 (patch)
tree4f1a011d0bba622983a6c974650aa4848f2124c2 /dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild
parentVersion bump for Gnome 2.32. (diff)
downloadgentoo-2-0d1e8ce23f7114b9de794579bbc04a47a0391390.tar.gz
gentoo-2-0d1e8ce23f7114b9de794579bbc04a47a0391390.tar.bz2
gentoo-2-0d1e8ce23f7114b9de794579bbc04a47a0391390.zip
Moved from dev-libs to dev-lua. Added myself to metadata.xml.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild')
-rw-r--r--dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild b/dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild
new file mode 100644
index 000000000000..1288600c0654
--- /dev/null
+++ b/dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luafilesystem/luafilesystem-1.4.1.ebuild,v 1.1 2010/11/05 23:12:31 rafaelmartins Exp $
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="File System Library for the Lua Programming Language"
+HOMEPAGE="http://www.keplerproject.org/luafilesystem/"
+SRC_URI="http://luaforge.net/frs/download.php/3345/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/lua-5.1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s|/usr/local|/usr|" \
+ -e "s|/lib|/$(get_libdir)|" \
+ -e "s|-O2|${CFLAGS}|" \
+ -e "s|gcc|$(tc-getCC)|" \
+ config || die
+}
+
+src_install() {
+ emake PREFIX="${D}usr" install || die
+ dodoc README
+ dohtml doc/us/*
+}