summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-07-18 18:53:37 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-07-18 18:53:37 +0000
commitca574241323574b1ce6884cd2ed8396cd209b975 (patch)
tree16cb1b36188a32e008ec78155eb55838e70c9a08 /dev-lua
parentCleanup (diff)
downloadgentoo-2-ca574241323574b1ce6884cd2ed8396cd209b975.tar.gz
gentoo-2-ca574241323574b1ce6884cd2ed8396cd209b975.tar.bz2
gentoo-2-ca574241323574b1ce6884cd2ed8396cd209b975.zip
version bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luvit/ChangeLog9
-rw-r--r--dev-lua/luvit/luvit-0.8.2.ebuild94
2 files changed, 101 insertions, 2 deletions
diff --git a/dev-lua/luvit/ChangeLog b/dev-lua/luvit/ChangeLog
index 1a7a6417ee12..a1f839a54fcb 100644
--- a/dev-lua/luvit/ChangeLog
+++ b/dev-lua/luvit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lua/luvit
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/ChangeLog,v 1.5 2013/12/14 14:13:10 hasufell Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/ChangeLog,v 1.6 2014/07/18 18:53:37 hasufell Exp $
+
+*luvit-0.8.2 (18 Jul 2014)
+
+ 18 Jul 2014; Julian Ospald <hasufell@gentoo.org> +luvit-0.8.2.ebuild:
+ version bump
*luvit-0.7.0 (14 Dec 2013)
diff --git a/dev-lua/luvit/luvit-0.8.2.ebuild b/dev-lua/luvit/luvit-0.8.2.ebuild
new file mode 100644
index 000000000000..0d53fc4def49
--- /dev/null
+++ b/dev-lua/luvit/luvit-0.8.2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/luvit-0.8.2.ebuild,v 1.1 2014/07/18 18:53:37 hasufell Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs multilib
+
+# TODO: FHS https://github.com/luvit/luvit/issues/379
+
+DESCRIPTION="Takes node.js' architecture and dependencies and fits it in the Lua language"
+HOMEPAGE="http://luvit.io/"
+SRC_URI="http://luvit.io/dist/latest/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="bundled-libs examples"
+# luvit Apache-2.0
+# luajit MIT
+# yajl BSD
+LICENSE="Apache-2.0 bundled-libs? ( BSD MIT )"
+
+# fails in portage environment
+# succeeds if run manually
+RESTRICT="test"
+
+RDEPEND="
+ dev-libs/openssl:0
+ sys-libs/zlib
+ !bundled-libs? (
+ dev-lang/luajit:2[lua52compat]
+ >=dev-libs/yajl-2.0.2
+ net-libs/http-parser
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ rm -r deps/{openssl,zlib} || die
+ epatch "${FILESDIR}"/${PN}-0.7.0-unbundle-http-parser.patch
+ if use bundled-libs ; then
+ sed -i \
+ -e "s/-Werror//" \
+ -e "s/-O3//" \
+ deps/http-parser/Makefile || die "fixing flags failed!"
+ else
+ rm -r deps/{luajit,yajl,http-parser} || die
+ # TODO: no version detection for http-parser yet
+ MY_YAJL_VERSION=$($(tc-getPKG_CONFIG) --modversion yajl)
+ MY_LUAJIT_VERSION=$($(tc-getPKG_CONFIG) --modversion luajit)
+ sed -i \
+ -e "s:^YAJL_VERSION=.*:YAJL_VERSION=${MY_YAJL_VERSION}:" \
+ -e "s:^LUAJIT_VERSION=.*:LUAJIT_VERSION=${MY_LUAJIT_VERSION}:" \
+ Makefile || die "setting yajl version failed"
+ fi
+
+}
+
+src_configure() {
+ # skip retarded gyp build system
+ :
+}
+
+src_compile() {
+ tc-export CC AR
+
+ emake -C deps/cares
+
+ myemakeargs=(
+ DEBUG=0
+ WERROR=0
+ USE_SYSTEM_SSL=1
+ # bundled luajit is compiled with special flags
+ USE_SYSTEM_LUAJIT=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_YAJL=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_HTTPPARSER=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_ZLIB=1
+ PREFIX=/usr
+ LIBDIR="${D%/}"/usr/$(get_libdir)/${PN}
+ DESTDIR="${D}"
+ )
+
+ emake "${myemakeargs[@]}" all
+}
+
+src_install() {
+ emake "${myemakeargs[@]}" install
+ dodoc TODO ChangeLog README.markdown errors.markdown
+
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}