summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-02-09 00:29:07 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-02-09 00:29:07 +0000
commit924c9e5815bb10891f1bce1c2fce6c8dbd9fc576 (patch)
treed500168e3f9c268291f18ff9680e1cf6b1d8e0f0 /dev-ml/bin-prot/bin-prot-109.08.00.ebuild
parentversion bump (diff)
downloadgentoo-2-924c9e5815bb10891f1bce1c2fce6c8dbd9fc576.tar.gz
gentoo-2-924c9e5815bb10891f1bce1c2fce6c8dbd9fc576.tar.bz2
gentoo-2-924c9e5815bb10891f1bce1c2fce6c8dbd9fc576.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/bin-prot/bin-prot-109.08.00.ebuild')
-rw-r--r--dev-ml/bin-prot/bin-prot-109.08.00.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/bin-prot-109.08.00.ebuild b/dev-ml/bin-prot/bin-prot-109.08.00.ebuild
new file mode 100644
index 000000000000..69c448f5b654
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-109.08.00.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-109.08.00.ebuild,v 1.1 2013/02/09 00:29:07 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV}/individual/${MY_P}.tar.gz
+ http://dev.gentoo.org/~aballier/distfiles/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/type-conv-3.0.5:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+
+DOCS=( "README.md" "CHANGES.txt" )
+S="${WORKDIR}/${MY_P}"