summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-09 10:45:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-09 10:45:32 +0000
commit3abd20572c9d461e5b69d77d040ee0436dfa989b (patch)
tree5ec3210cf0f6d36b1f47ce95ea29949d6eca372b /dev-ml/bin-prot
parentstable x86, bug 308521 (diff)
downloadgentoo-2-3abd20572c9d461e5b69d77d040ee0436dfa989b.tar.gz
gentoo-2-3abd20572c9d461e5b69d77d040ee0436dfa989b.tar.bz2
gentoo-2-3abd20572c9d461e5b69d77d040ee0436dfa989b.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/ChangeLog7
-rw-r--r--dev-ml/bin-prot/bin-prot-1.2.23.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index 12bdb671e57d..fad542753b42 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/bin-prot
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.3 2010/01/03 15:20:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.4 2010/04/09 10:45:32 aballier Exp $
+
+*bin-prot-1.2.23 (09 Apr 2010)
+
+ 09 Apr 2010; Alexis Ballier <aballier@gentoo.org> +bin-prot-1.2.23.ebuild:
+ version bump
*bin-prot-1.2.21 (03 Jan 2010)
diff --git a/dev-ml/bin-prot/bin-prot-1.2.23.ebuild b/dev-ml/bin-prot/bin-prot-1.2.23.ebuild
new file mode 100644
index 000000000000..5a0233931e35
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-1.2.23.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.2.23.ebuild,v 1.1 2010/04/09 10:45:32 aballier Exp $
+
+EAPI="2"
+
+inherit findlib
+
+DESCRIPTION="Automated code generation for converting OCaml values to/from a type-safe binary protocol"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+S=${WORKDIR}/${P}/lib
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
+ dev-ml/type-conv"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )
+ doc? ( virtual/latex-base )"
+
+src_compile() {
+ emake -j1 CFLAGS="${CFLAGS}" || die
+ if use doc; then
+ cd ../doc
+ VARTEXFONTS="${T}/fonts" pdflatex README.tex || die
+ fi
+}
+
+src_test() {
+ cd "${S}/../lib_test"
+ emake -j1 || die
+ ./test_runner || die
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die "make install failed"
+ dodoc ../README.txt ../Changelog
+ use doc && dodoc ../doc/README.pdf
+}