summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-15 21:01:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-15 21:01:15 +0000
commit3cc3f3e8b013d2847beebd661b91c50080160007 (patch)
treed7d2879403f95abf94c78a88413cbc4d4f6722a1 /dev-ml/camlimages
parentbabl 0.1.4 version bump (diff)
downloadgentoo-2-3cc3f3e8b013d2847beebd661b91c50080160007.tar.gz
gentoo-2-3cc3f3e8b013d2847beebd661b91c50080160007.tar.bz2
gentoo-2-3cc3f3e8b013d2847beebd661b91c50080160007.zip
Fix build with libpng 1.5
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camlimages')
-rw-r--r--dev-ml/camlimages/ChangeLog8
-rw-r--r--dev-ml/camlimages/camlimages-3.0.2.ebuild7
-rw-r--r--dev-ml/camlimages/files/camlimages-3.0.2-libpng15.patch62
3 files changed, 72 insertions, 5 deletions
diff --git a/dev-ml/camlimages/ChangeLog b/dev-ml/camlimages/ChangeLog
index 1360427422ef..16f0de72583c 100644
--- a/dev-ml/camlimages/ChangeLog
+++ b/dev-ml/camlimages/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/camlimages
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.28 2010/04/24 12:20:50 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.29 2011/02/15 21:01:15 aballier Exp $
+
+ 15 Feb 2011; Alexis Ballier <aballier@gentoo.org> camlimages-3.0.2.ebuild,
+ +files/camlimages-3.0.2-libpng15.patch:
+ Fix build with libpng 1.5
24 Apr 2010; Alexis Ballier <aballier@gentoo.org>
-camlimages-3.0.1.ebuild, -files/camlimages-3.0.1-CVE-2009-2295.patch,
diff --git a/dev-ml/camlimages/camlimages-3.0.2.ebuild b/dev-ml/camlimages/camlimages-3.0.2.ebuild
index 087db3b9d797..2a16b1650092 100644
--- a/dev-ml/camlimages/camlimages-3.0.2.ebuild
+++ b/dev-ml/camlimages/camlimages-3.0.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/camlimages-3.0.2.ebuild,v 1.7 2010/04/15 14:47:40 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/camlimages-3.0.2.ebuild,v 1.8 2011/02/15 21:01:15 aballier Exp $
EAPI=2
@@ -22,7 +22,7 @@ RDEPEND=">=dev-lang/ocaml-3.10.2[X,ocamlopt]
gs? ( app-text/ghostscript-gpl )
jpeg? ( media-libs/jpeg )
tiff? ( media-libs/tiff )
- media-libs/libpng
+ >=media-libs/libpng-1.4
truetype? ( >=media-libs/freetype-2 )
xpm? ( x11-libs/libXpm )
"
@@ -35,6 +35,7 @@ src_prepare() {
epatch "${FILESDIR}/${P}-ocaml-autoconf11.patch"
epatch "${FILESDIR}/${P}-annot.patch"
epatch "${FILESDIR}/${P}-noxpm.patch"
+ epatch "${FILESDIR}/${P}-libpng15.patch"
eautoreconf
}
diff --git a/dev-ml/camlimages/files/camlimages-3.0.2-libpng15.patch b/dev-ml/camlimages/files/camlimages-3.0.2-libpng15.patch
new file mode 100644
index 000000000000..366a14c0de9a
--- /dev/null
+++ b/dev-ml/camlimages/files/camlimages-3.0.2-libpng15.patch
@@ -0,0 +1,62 @@
+Index: camlimages-3.0.2/src/pngread.c
+===================================================================
+--- camlimages-3.0.2.orig/src/pngread.c
++++ camlimages-3.0.2/src/pngread.c
+@@ -69,7 +69,7 @@ value read_png_file_as_rgb24( name )
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -134,7 +134,7 @@ value read_png_file_as_rgb24( name )
+ png_set_rows(png_ptr, info_ptr, row_pointers);
+
+ /* Later, we can return something */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -243,7 +243,7 @@ value read_png_file( name )
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -302,7 +302,7 @@ value read_png_file( name )
+ png_set_rows(png_ptr, info_ptr, row_pointers);
+
+ /* Later, we can return something */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+Index: camlimages-3.0.2/src/pngwrite.c
+===================================================================
+--- camlimages-3.0.2.orig/src/pngwrite.c
++++ camlimages-3.0.2/src/pngwrite.c
+@@ -62,7 +62,7 @@ value write_png_file_rgb( name, buffer,
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+@@ -171,7 +171,7 @@ value write_png_file_index( name, buffer
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);