summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Buisse <nattfodd@gentoo.org>2007-02-06 21:26:43 +0000
committerAlexandre Buisse <nattfodd@gentoo.org>2007-02-06 21:26:43 +0000
commit511ef2d6a25c7f5bbf9d28a55a039e5925c75d1d (patch)
tree059ec017317b5c9bd540b8cfd6658ac787d54132 /dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
parentStable on amd64 wrt bug #161149. (diff)
downloadgentoo-2-511ef2d6a25c7f5bbf9d28a55a039e5925c75d1d.tar.gz
gentoo-2-511ef2d6a25c7f5bbf9d28a55a039e5925c75d1d.tar.bz2
gentoo-2-511ef2d6a25c7f5bbf9d28a55a039e5925c75d1d.zip
Initial commit.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild')
-rw-r--r--dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
new file mode 100644
index 000000000000..f264870e346c
--- /dev/null
+++ b/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-expat/ocaml-expat-0.9.1.ebuild,v 1.1 2007/02/06 21:26:43 nattfodd Exp $
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for expat"
+SRC_URI="http://www.xs4all.nl/~mmzeeman/ocaml/${P}.tar.gz"
+HOMEPAGE="http://www.xs4all.nl/~mmzeeman/ocaml/"
+
+DEPEND="dev-libs/expat"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86"
+
+src_compile() {
+ emake depend all allopt || die "make failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die
+
+ if use doc ; then
+ dohtml -r doc/html/*
+ fi
+ dodoc README
+}