summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-03-18 16:47:50 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-03-18 16:47:50 +0000
commit27a0ecc3d1848a050a655efeca6fb28d3e31df78 (patch)
treed55875ed75164f4ed2e879ac473a5c376c06c606 /dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild
parentchangelog header fix (diff)
downloadgentoo-2-27a0ecc3d1848a050a655efeca6fb28d3e31df78.tar.gz
gentoo-2-27a0ecc3d1848a050a655efeca6fb28d3e31df78.tar.bz2
gentoo-2-27a0ecc3d1848a050a655efeca6fb28d3e31df78.zip
Version bump.
Diffstat (limited to 'dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild')
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild
new file mode 100644
index 000000000000..7cab15b4850a
--- /dev/null
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.7.2.ebuild,v 1.1 2005/03/18 16:47:50 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="OCaml SDL Bindings"
+
+HOMEPAGE="http://ocamlsdl.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc opengl truetype" #noimage nomixer
+
+DEPEND=">=dev-lang/ocaml-3.04
+>=media-libs/libsdl-1.2
+opengl? ( >=dev-ml/lablgl-0.98 )
+>=media-libs/sdl-mixer-1.2
+>=media-libs/sdl-image-1.2
+truetype? ( >=media-libs/sdl-ttf-2.0 )"
+
+src_compile() {
+ myconf=""
+ if use opengl; then
+ destdir=`ocamlfind printconf destdir`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ if [ -z "${lablgldir}" ]; then
+ destdir=`ocamlc -where`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ fi
+
+ if [ ! -z "${lablgldir}" ]; then
+ myconf="--with-lablgldir=${lablgldir}"
+ fi
+ fi
+
+ #use noimage && myconf="${myconf} --without-sdl-image"
+ #use nomixer && myconf="${myconf} --without-sdl-mixer"
+
+ econf $myconf \
+ `use_enable truetype sdl-ttf` \
+ || die
+ emake all || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc AUTHORS NEWS README
+ doinfo doc/*.info*
+
+ if use doc; then
+ dohtml doc/html/*
+ fi
+}