summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-03-27 21:06:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-03-27 21:06:32 +0000
commit23c96c3505026c4cbaad082efe214aa9aa3fbb10 (patch)
tree539facab83c5a89a98d3c9a6aaaf1f798649d512 /dev-ml/ounit/ounit-1.1.1.ebuild
parentconvert to oasis.eclass (diff)
downloadgentoo-2-23c96c3505026c4cbaad082efe214aa9aa3fbb10.tar.gz
gentoo-2-23c96c3505026c4cbaad082efe214aa9aa3fbb10.tar.bz2
gentoo-2-23c96c3505026c4cbaad082efe214aa9aa3fbb10.zip
convert to oasis.eclass
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ounit/ounit-1.1.1.ebuild')
-rw-r--r--dev-ml/ounit/ounit-1.1.1.ebuild41
1 files changed, 8 insertions, 33 deletions
diff --git a/dev-ml/ounit/ounit-1.1.1.ebuild b/dev-ml/ounit/ounit-1.1.1.ebuild
index fd0a797abb90..dd0de6c9e17a 100644
--- a/dev-ml/ounit/ounit-1.1.1.ebuild
+++ b/dev-ml/ounit/ounit-1.1.1.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.1.1.ebuild,v 1.1 2012/01/28 19:21:57 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.1.1.ebuild,v 1.2 2012/03/27 21:06:32 aballier Exp $
-EAPI="2"
+EAPI="3"
-inherit findlib multilib
+OASIS_BUILD_DOCS=1
+
+inherit oasis
DESCRIPTION="Unit testing framework for OCaml"
HOMEPAGE="http://ounit.forge.ocamlcore.org/"
@@ -12,35 +14,8 @@ SRC_URI="http://forge.ocamlcore.org/frs/download.php/762/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]"
+DEPEND=""
RDEPEND="${DEPEND}"
-IUSE="debug doc +ocamlopt"
-
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
-
-src_configure() {
- chmod +x configure
- ./configure --prefix usr \
- --libdir /usr/$(get_libdir) \
- --docdir /usr/share/doc/${PF}/html \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- || die
-}
-
-src_compile() {
- emake || die
- if use doc ; then
- emake doc || die
- fi
-}
-
-src_install() {
- findlib_src_install
+IUSE=""
- # install documentation
- dodoc README* AUTHORS* changelog || die
-}
+DOCS=( "README.txt" "AUTHORS.txt" "changelog" )