summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-01 10:21:45 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-01 10:21:45 +0000
commite102398ba10c3a0552a947ece1519a1c811de3e8 (patch)
tree031c938e6f7654e41a07f205c2985cf7490e6b9d /dev-ml/reactiveData
parentUpdate kernel deps according to oprofile's html docs (diff)
downloadgentoo-2-e102398ba10c3a0552a947ece1519a1c811de3e8.tar.gz
gentoo-2-e102398ba10c3a0552a947ece1519a1c811de3e8.tar.bz2
gentoo-2-e102398ba10c3a0552a947ece1519a1c811de3e8.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/reactiveData')
-rw-r--r--dev-ml/reactiveData/ChangeLog10
-rw-r--r--dev-ml/reactiveData/metadata.xml5
-rw-r--r--dev-ml/reactiveData/reactiveData-0.1.ebuild37
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/reactiveData/ChangeLog b/dev-ml/reactiveData/ChangeLog
new file mode 100644
index 000000000000..409d35b70431
--- /dev/null
+++ b/dev-ml/reactiveData/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/reactiveData
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/reactiveData/ChangeLog,v 1.1 2014/12/01 10:21:45 aballier Exp $
+
+*reactiveData-0.1 (01 Dec 2014)
+
+ 01 Dec 2014; Alexis Ballier <aballier@gentoo.org> +reactiveData-0.1.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/reactiveData/metadata.xml b/dev-ml/reactiveData/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/reactiveData/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/reactiveData/reactiveData-0.1.ebuild b/dev-ml/reactiveData/reactiveData-0.1.ebuild
new file mode 100644
index 000000000000..77833afbdc0e
--- /dev/null
+++ b/dev-ml/reactiveData/reactiveData-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/reactiveData/reactiveData-0.1.ebuild,v 1.1 2014/12/01 10:21:45 aballier Exp $
+
+EAPI="5"
+
+DESCRIPTION="Functional reactive programming with incremental changes in data structures"
+HOMEPAGE="https://github.com/hhugo/reactiveData"
+SRC_URI="https://github.com/hhugo/reactiveData/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ dev-ml/react:="
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc README.md
+}