summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-01-26 13:54:58 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-01-26 13:54:58 +0000
commit8080b0812e6c4f27ea51175cf20c22e32bda73be (patch)
tree8c298cbda219bcde3feda71185ae9212a040c55c /dev-ml/uutf
parent Unquoted Variable warning (diff)
downloadgentoo-2-8080b0812e6c4f27ea51175cf20c22e32bda73be.tar.gz
gentoo-2-8080b0812e6c4f27ea51175cf20c22e32bda73be.tar.bz2
gentoo-2-8080b0812e6c4f27ea51175cf20c22e32bda73be.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/uutf')
-rw-r--r--dev-ml/uutf/ChangeLog10
-rw-r--r--dev-ml/uutf/metadata.xml3
-rw-r--r--dev-ml/uutf/uutf-0.9.4.ebuild51
3 files changed, 62 insertions, 2 deletions
diff --git a/dev-ml/uutf/ChangeLog b/dev-ml/uutf/ChangeLog
index 834761a3e277..8791a9cec926 100644
--- a/dev-ml/uutf/ChangeLog
+++ b/dev-ml/uutf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/uutf
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/uutf/ChangeLog,v 1.1 2014/10/29 08:41:19 aballier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/uutf/ChangeLog,v 1.2 2015/01/26 13:54:58 aballier Exp $
+
+*uutf-0.9.4 (26 Jan 2015)
+
+ 26 Jan 2015; Alexis Ballier <aballier@gentoo.org> +uutf-0.9.4.ebuild,
+ metadata.xml:
+ version bump
*uutf-0.9.3 (29 Oct 2014)
diff --git a/dev-ml/uutf/metadata.xml b/dev-ml/uutf/metadata.xml
index 2193d772e351..959de7257d5d 100644
--- a/dev-ml/uutf/metadata.xml
+++ b/dev-ml/uutf/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>ml</herd>
+<use>
+<flag name="utftrip">Builds and install the utftrip executable: Among other things, reads unicode on stdin and rewrites it on stdout.</flag>
+</use>
</pkgmetadata>
diff --git a/dev-ml/uutf/uutf-0.9.4.ebuild b/dev-ml/uutf/uutf-0.9.4.ebuild
new file mode 100644
index 000000000000..7494c84c3a5f
--- /dev/null
+++ b/dev-ml/uutf/uutf-0.9.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/uutf/uutf-0.9.4.ebuild,v 1.1 2015/01/26 13:54:58 aballier Exp $
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="Non-blocking streaming Unicode codec for OCaml"
+HOMEPAGE="http://erratique.ch/software/uutf"
+SRC_URI="http://erratique.ch/software/uutf/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="utftrip +ocamlopt doc"
+
+RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
+ utftrip? ( dev-ml/cmdliner:= )"
+DEPEND="${RDEPEND}"
+# https://github.com/dbuenzli/uutf/issues/3
+RESTRICT="test"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ cmdliner=$(usex utftrip true false) \
+ || die
+}
+
+src_test() {
+ if use ocamlopt ; then
+ ocamlbuild tests.otarget || die
+ cd _build/test || die
+ ./test.native || die
+ else
+ ewarn "Sorry, ${PN} tests require native support (ocamlopt)"
+ fi
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs=""
+ use ocamlopt && nativelibs="$(echo _build/src/uutf.cm{x,xa,xs} _build/src/uutf.a)"
+ ocamlfind install uutf _build/pkg/META _build/src/uutf.mli _build/src/uutf.cm{a,i} ${nativelibs} || die
+ use utftrip && newbin utftrip.$(usex ocamlopt native byte) utftrip
+ dodoc CHANGES.md README.md
+ use doc && dohtml -r doc/*
+}