summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-11-10 22:53:15 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-11-10 22:53:15 +0000
commit0154b358d6def0f2b6a3b44ce51a729031331679 (patch)
tree13ecb397e4a592ca4feaee4860c9022fa77993d7 /dev-ml
parentForgot to update & commit it with the bump (diff)
downloadgentoo-2-0154b358d6def0f2b6a3b44ce51a729031331679.tar.gz
gentoo-2-0154b358d6def0f2b6a3b44ce51a729031331679.tar.bz2
gentoo-2-0154b358d6def0f2b6a3b44ce51a729031331679.zip
Version bump, ocaml-3.09 compliant.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pxp/ChangeLog7
-rw-r--r--dev-ml/pxp/Manifest8
-rw-r--r--dev-ml/pxp/files/digest-pxp-1.1.961
-rw-r--r--dev-ml/pxp/pxp-1.1.96.ebuild39
4 files changed, 51 insertions, 4 deletions
diff --git a/dev-ml/pxp/ChangeLog b/dev-ml/pxp/ChangeLog
index f68a573a7ede..a454c33bf9a1 100644
--- a/dev-ml/pxp/ChangeLog
+++ b/dev-ml/pxp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pxp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.10 2005/03/09 00:22:40 mattam Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/ChangeLog,v 1.11 2005/11/10 22:53:15 mattam Exp $
+
+*pxp-1.1.95 (10 Nov 2005)
+
+ 10 Nov 2005; Matthieu Sozeau <mattam@gentoo.org> +pxp-1.1.96.ebuild:
+ Version bump, compatible with ocaml 3.09.
*pxp-1.1.95 (09 Mar 2005)
diff --git a/dev-ml/pxp/Manifest b/dev-ml/pxp/Manifest
index f338f13bee80..fa2e1e5ad5f6 100644
--- a/dev-ml/pxp/Manifest
+++ b/dev-ml/pxp/Manifest
@@ -1,6 +1,8 @@
-MD5 80605662d15727a698a112d18aaedba8 ChangeLog 1196
-MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 33487038574cd2aad6a393386a475cfc pxp-1.1.6.ebuild 969
+MD5 81a1aa6a61f1901ee44d682b0951bc8c pxp-1.1.96.ebuild 978
MD5 81a1aa6a61f1901ee44d682b0951bc8c pxp-1.1.95.ebuild 978
-MD5 cc510152563ebbd7b5b9f13f5bbbf3aa files/digest-pxp-1.1.6 61
+MD5 80605662d15727a698a112d18aaedba8 ChangeLog 1196
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
MD5 80a9e9164ea33afa62da74738d4415cd files/digest-pxp-1.1.95 62
+MD5 bd7eb8f270559fe43a40c6ffffce5a31 files/digest-pxp-1.1.96 62
+MD5 cc510152563ebbd7b5b9f13f5bbbf3aa files/digest-pxp-1.1.6 61
diff --git a/dev-ml/pxp/files/digest-pxp-1.1.96 b/dev-ml/pxp/files/digest-pxp-1.1.96
new file mode 100644
index 000000000000..d9f65a9d1c95
--- /dev/null
+++ b/dev-ml/pxp/files/digest-pxp-1.1.96
@@ -0,0 +1 @@
+MD5 686c4688980126b4711800b33a403d17 pxp-1.1.96.tar.gz 369803
diff --git a/dev-ml/pxp/pxp-1.1.96.ebuild b/dev-ml/pxp/pxp-1.1.96.ebuild
new file mode 100644
index 000000000000..81d7eb9103a4
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.1.96.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pxp/pxp-1.1.96.ebuild,v 1.1 2005/11/10 22:53:15 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://www.ocaml-programming.de/packages/documentation/pxp/index_dev.html"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc"
+
+SLOT="0"
+DEPEND=">=dev-ml/pcre-ocaml-4.31
+>=dev-ml/ulex-0.5
+>=dev-ml/ocamlnet-0.98"
+
+IUSE="doc"
+
+src_compile() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die
+ make all opt || die
+}
+
+src_install() {
+ findlib_src_install
+
+ cd doc
+ dodoc ABOUT-FINDLIB DEV EXTENSIONS INSTALL README RELEASE-NOTES SPEC design.txt
+
+ if use doc; then
+ dodoc manual/ps/pxp.ps
+ dohtml manual/html/*
+ insinto /usr/share/doc/${PF}/html/pic
+ doins manual/html/pic/*
+ fi
+}