summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-09 16:06:15 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-09 16:06:15 +0000
commit2f3eb49835fcaa8b1af0ff52662616d5cda04b0b (patch)
tree0dfe8d6b369a81a4775886032d2cda52c681e1e6 /dev-ml
parentalpha/ia64/s390/sh/sparc stable wrt #428900 (diff)
downloadgentoo-2-2f3eb49835fcaa8b1af0ff52662616d5cda04b0b.tar.gz
gentoo-2-2f3eb49835fcaa8b1af0ff52662616d5cda04b0b.tar.bz2
gentoo-2-2f3eb49835fcaa8b1af0ff52662616d5cda04b0b.zip
version bump
(Portage version: 2.2.0_alpha125/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lwt/ChangeLog7
-rw-r--r--dev-ml/lwt/lwt-2.4.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ml/lwt/ChangeLog b/dev-ml/lwt/ChangeLog
index 21ce54cf9e83..3bc50884205c 100644
--- a/dev-ml/lwt/ChangeLog
+++ b/dev-ml/lwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lwt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.20 2012/08/07 16:31:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.21 2012/09/09 16:06:15 aballier Exp $
+
+*lwt-2.4.1 (09 Sep 2012)
+
+ 09 Sep 2012; Alexis Ballier <aballier@gentoo.org> +lwt-2.4.1.ebuild:
+ version bump
07 Aug 2012; Alexis Ballier <aballier@gentoo.org> -lwt-2.3.2.ebuild:
remove old
diff --git a/dev-ml/lwt/lwt-2.4.1.ebuild b/dev-ml/lwt/lwt-2.4.1.ebuild
new file mode 100644
index 000000000000..e425384c37bf
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-2.4.1.ebuild,v 1.1 2012/09/09 16:06:15 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="http://ocsigen.org/download/${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl"
+
+DEPEND="react? ( dev-ml/react )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0 )
+ gtk? ( dev-ml/lablgtk dev-libs/glib:2 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+DOCS=( "CHANGES" "CHANGES.darcs" "README" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)" \
+ oasis_src_configure
+}