summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-12-01 08:56:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-12-01 08:56:40 +0000
commit489b47b3c3f561b4f43d5ab71ea0c242434c790c (patch)
tree8a7bb2cd73eba81f3664ccfae6c887b87346f667 /dev-ml
parentStable for ppc64, wrt bug #513430 (diff)
downloadgentoo-2-489b47b3c3f561b4f43d5ab71ea0c242434c790c.tar.gz
gentoo-2-489b47b3c3f561b4f43d5ab71ea0c242434c790c.tar.bz2
gentoo-2-489b47b3c3f561b4f43d5ab71ea0c242434c790c.zip
version bump, update homepage/src_uri
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pomap/ChangeLog7
-rw-r--r--dev-ml/pomap/pomap-3.0.5.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ml/pomap/ChangeLog b/dev-ml/pomap/ChangeLog
index 2775877ed5df..d40fad25a66b 100644
--- a/dev-ml/pomap/ChangeLog
+++ b/dev-ml/pomap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pomap
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/ChangeLog,v 1.38 2014/11/28 17:38:48 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/ChangeLog,v 1.39 2014/12/01 08:56:40 aballier Exp $
+
+*pomap-3.0.5 (01 Dec 2014)
+
+ 01 Dec 2014; Alexis Ballier <aballier@gentoo.org> +pomap-3.0.5.ebuild:
+ version bump, update homepage/src_uri
28 Nov 2014; Alexis Ballier <aballier@gentoo.org> pomap-3.0.3.ebuild:
update deps for ocaml 4.02
diff --git a/dev-ml/pomap/pomap-3.0.5.ebuild b/dev-ml/pomap/pomap-3.0.5.ebuild
new file mode 100644
index 000000000000..84c44ff6b379
--- /dev/null
+++ b/dev-ml/pomap/pomap-3.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pomap/pomap-3.0.5.ebuild,v 1.1 2014/12/01 08:56:40 aballier Exp $
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Partially Ordered Map ADT for O'Caml"
+HOMEPAGE="http://mmottl.github.io/pomap/"
+SRC_URI="https://github.com/mmottl/pomap/releases/download/v${PV}/${P}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+
+DEPEND="|| ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 )"
+RDEPEND="${DEPEND}"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="examples"
+
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" )
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}