summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-09-26 13:03:47 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-09-26 13:03:47 +0000
commit7afddb68396116e9b1aaaf318c03b98c5dc74292 (patch)
tree6fbd2c8f2d35cd45afcde87ff0047ee4a42d0157 /dev-ml
parentversion bump (diff)
downloadgentoo-2-7afddb68396116e9b1aaaf318c03b98c5dc74292.tar.gz
gentoo-2-7afddb68396116e9b1aaaf318c03b98c5dc74292.tar.bz2
gentoo-2-7afddb68396116e9b1aaaf318c03b98c5dc74292.zip
version bump
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lablgtk/ChangeLog7
-rw-r--r--dev-ml/lablgtk/lablgtk-2.14.0.ebuild81
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-ml/lablgtk/ChangeLog b/dev-ml/lablgtk/ChangeLog
index 8f0421a5ac7e..082480e062ce 100644
--- a/dev-ml/lablgtk/ChangeLog
+++ b/dev-ml/lablgtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lablgtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.69 2009/09/18 23:49:34 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/ChangeLog,v 1.70 2009/09/26 13:03:47 aballier Exp $
+
+*lablgtk-2.14.0 (26 Sep 2009)
+
+ 26 Sep 2009; Alexis Ballier <aballier@gentoo.org> +lablgtk-2.14.0.ebuild:
+ version bump
*lablgtk-2.12.0-r1 (18 Sep 2009)
diff --git a/dev-ml/lablgtk/lablgtk-2.14.0.ebuild b/dev-ml/lablgtk/lablgtk-2.14.0.ebuild
new file mode 100644
index 000000000000..9b66f8a46d00
--- /dev/null
+++ b/dev-ml/lablgtk/lablgtk-2.14.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lablgtk/lablgtk-2.14.0.ebuild,v 1.1 2009/09/26 13:03:47 aballier Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+IUSE="debug examples glade gnome gnomecanvas sourceview +ocamlopt opengl spell svg"
+
+DESCRIPTION="Objective CAML interface for Gtk+2"
+HOMEPAGE="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html"
+SRC_URI="http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/dist/${P}.tar.gz"
+LICENSE="LGPL-2.1 as-is"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-lang/ocaml-3.10[ocamlopt?]
+ svg? ( >=gnome-base/librsvg-2.2 )
+ glade? ( >=gnome-base/libglade-2.0.1 )
+ gnomecanvas? ( >=gnome-base/libgnomecanvas-2.2 )
+ gnome? ( >=gnome-base/gnome-panel-2.4.0
+ >=gnome-base/libgnomeui-2.4.0 )
+ opengl? ( >=dev-ml/lablgl-0.98
+ >=x11-libs/gtkglarea-1.9 )
+ spell? ( app-text/gtkspell )
+ sourceview? ( x11-libs/gtksourceview:1.0 )
+ "
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_with svg rsvg) \
+ $(use_with glade) \
+ $(use_with gnome gnomeui) \
+ $(use_with gnome panel) \
+ $(use_with opengl gl) \
+ $(use_with spell gtkspell) \
+ --without-gtksourceview2 \
+ $(use_with sourceview gtksourceview) \
+ $(use_with gnomecanvas)
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code failed"
+ fi
+}
+
+install_examples() {
+ insinto /usr/share/doc/${P}/examples
+ doins examples/*.ml examples/*.rgb examples/*.png examples/*.xpm
+
+ # Install examples for optional components
+ use gnomecanvas && insinto /usr/share/doc/${P}/examples/canvas && doins examples/canvas/*.ml examples/canvas/*.png
+ use svg && insinto /usr/share/doc/${P}/examples/rsvg && doins examples/rsvg/*.ml examples/rsvg/*.svg
+ use glade && insinto /usr/share/doc/${P}/examples/glade && doins examples/glade/*.ml examples/glade/*.glade*
+ use sourceview && insinto /usr/share/doc/${P}/examples/sourceview && doins examples/sourceview/*.ml examples/sourceview/*.lang
+ use opengl && insinto /usr/share/doc/${P}/examples/GL && doins examples/GL/*.ml
+ use gnome && insinto /usr/share/doc/${P}/examples/panel && doins examples/panel/*
+}
+
+src_install () {
+ emake install DESTDIR="${D}" || die
+
+ # ocamlfind support
+ insinto /usr/$(get_libdir)/ocaml/lablgtk2
+ doins META
+
+ dodoc CHANGES README CHANGES.API
+ use examples && install_examples
+}
+
+pkg_postinst () {
+ use examples && elog "To run the examples you can use the lablgtk2 toplevel."
+ use examples && elog "e.g: lablgtk2 /usr/share/doc/${P}/examples/testgtk.ml"
+}