summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-19 18:51:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-19 18:51:53 +0000
commit8071d2ec9efe79c3cddb303a37653d044811b3dc (patch)
tree4bba8bdd2029f51231124e9b2a146c106883ba3c /dev-ml
parentversion bump (diff)
downloadgentoo-2-8071d2ec9efe79c3cddb303a37653d044811b3dc.tar.gz
gentoo-2-8071d2ec9efe79c3cddb303a37653d044811b3dc.tar.bz2
gentoo-2-8071d2ec9efe79c3cddb303a37653d044811b3dc.zip
version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlsdl/ChangeLog9
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.8.0.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/dev-ml/ocamlsdl/ChangeLog b/dev-ml/ocamlsdl/ChangeLog
index 587fedb3492c..3366b6f7aa93 100644
--- a/dev-ml/ocamlsdl/ChangeLog
+++ b/dev-ml/ocamlsdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlsdl
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ChangeLog,v 1.11 2008/01/04 01:31:09 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ChangeLog,v 1.12 2011/04/19 18:51:53 aballier Exp $
+
+*ocamlsdl-0.8.0 (19 Apr 2011)
+
+ 19 Apr 2011; Alexis Ballier <aballier@gentoo.org> +ocamlsdl-0.8.0.ebuild:
+ version bump
04 Jan 2008; Alexis Ballier <aballier@gentoo.org> ocamlsdl-0.7.2.ebuild:
~amd64, working fine here
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.8.0.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.8.0.ebuild
new file mode 100644
index 000000000000..c27c191a830f
--- /dev/null
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.8.0.ebuild,v 1.1 2011/04/19 18:51:53 aballier Exp $
+
+inherit findlib
+
+DESCRIPTION="OCaml SDL Bindings"
+
+HOMEPAGE="http://ocamlsdl.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc opengl truetype" #noimage nomixer
+
+DEPEND=">=dev-lang/ocaml-3.04
+>=media-libs/libsdl-1.2
+opengl? ( >=dev-ml/lablgl-0.98 )
+>=media-libs/sdl-mixer-1.2
+>=media-libs/sdl-image-1.2
+truetype? ( >=media-libs/sdl-ttf-2.0 )"
+
+src_compile() {
+ myconf=""
+ if use opengl; then
+ destdir=`ocamlfind printconf destdir`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ if [ -z "${lablgldir}" ]; then
+ destdir=`ocamlc -where`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ fi
+
+ if [ ! -z "${lablgldir}" ]; then
+ myconf="--with-lablgldir=${lablgldir}"
+ fi
+ fi
+
+ #use noimage && myconf="${myconf} --without-sdl-image"
+ #use nomixer && myconf="${myconf} --without-sdl-mixer"
+
+ econf $myconf \
+ `use_enable truetype sdl-ttf` \
+ || die
+ emake all || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc AUTHORS NEWS README || die
+ doinfo doc/*.info* || die
+
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+}