summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-05-25 11:04:59 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-05-25 11:04:59 +0000
commit83219583fa88af47f5c81df656c5c8cf24a73f1d (patch)
tree8f59367736a50ea6ee6c89e5718889b69368a044 /dev-ml
parentFix for build w/o tk, #319631; thanks Jonathan-Christofer Demay for digging o... (diff)
downloadgentoo-2-83219583fa88af47f5c81df656c5c8cf24a73f1d.tar.gz
gentoo-2-83219583fa88af47f5c81df656c5c8cf24a73f1d.tar.bz2
gentoo-2-83219583fa88af47f5c81df656c5c8cf24a73f1d.zip
remove old
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/ChangeLog6
-rw-r--r--dev-ml/findlib/findlib-1.2.4-r1.ebuild77
-rw-r--r--dev-ml/findlib/findlib-1.2.4.ebuild77
3 files changed, 5 insertions, 155 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
index e47dd7b009b2..6b629f44d0d1 100644
--- a/dev-ml/findlib/ChangeLog
+++ b/dev-ml/findlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/findlib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.58 2010/02/11 15:07:16 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.59 2010/05/25 11:04:59 aballier Exp $
+
+ 25 May 2010; Alexis Ballier <aballier@gentoo.org> -findlib-1.2.4.ebuild,
+ -findlib-1.2.4-r1.ebuild:
+ remove old
11 Feb 2010; Ulrich Mueller <ulm@gentoo.org> findlib-1.2.3.ebuild,
findlib-1.2.4.ebuild, findlib-1.2.4-r1.ebuild, findlib-1.2.5.ebuild:
diff --git a/dev-ml/findlib/findlib-1.2.4-r1.ebuild b/dev-ml/findlib/findlib-1.2.4-r1.ebuild
deleted file mode 100644
index baecfa6ecc47..000000000000
--- a/dev-ml/findlib/findlib-1.2.4-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.4-r1.ebuild,v 1.2 2010/02/11 15:07:16 ulm Exp $
-
-EAPI=2
-
-inherit multilib
-
-RESTRICT="installsources"
-
-DESCRIPTION="OCaml tool to find/use non-standard packages."
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?,tk?]"
-RDEPEND="${DEPEND}"
-
-ocamlfind_destdir="/usr/$(get_libdir)/ocaml"
-stublibs="${ocamlfind_destdir}/stublibs"
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir /usr/bin -mandir /usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake all || die
- if use ocamlopt; then
- emake opt || die # optimized code
- else
- # If using bytecode we dont want to strip the binary as it would remove the
- # bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
- fi
-}
-
-src_install() {
- dodir `ocamlc -where`
-
- emake prefix="${D}" install || die
-
- dodir "${stublibs}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}
diff --git a/dev-ml/findlib/findlib-1.2.4.ebuild b/dev-ml/findlib/findlib-1.2.4.ebuild
deleted file mode 100644
index 7b743a4b6ad8..000000000000
--- a/dev-ml/findlib/findlib-1.2.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-1.2.4.ebuild,v 1.2 2010/02/11 15:07:16 ulm Exp $
-
-EAPI=2
-
-inherit multilib
-
-RESTRICT="installsources"
-
-DESCRIPTION="OCaml tool to find/use non-standard packages."
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?,tk?]"
-RDEPEND="${DEPEND}"
-
-ocamlfind_destdir="/usr/$(get_libdir)/ocaml/site-packages"
-stublibs="${ocamlfind_destdir}/stublibs"
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir /usr/bin -mandir /usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake all || die
- if use ocamlopt; then
- emake opt || die # optimized code
- else
- # If using bytecode we dont want to strip the binary as it would remove the
- # bytecode and only leave ocamlrun...
- export STRIP_MASK="*/bin/*"
- fi
-}
-
-src_install() {
- dodir `ocamlc -where`
-
- emake prefix="${D}" install || die
-
- dodir "${stublibs}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}