summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-24 20:12:10 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-24 20:12:10 +0000
commit871b93fb6e87f2448b2d25b36c44d8912b7a0345 (patch)
treec62424feff384106f13bc6f2b9e8177a32f35b4e /dev-ml
parentversion bump by Vladimir Ivanov <v.ivanov@ymail.com>, bug #355519, with impro... (diff)
downloadgentoo-2-871b93fb6e87f2448b2d25b36c44d8912b7a0345.tar.gz
gentoo-2-871b93fb6e87f2448b2d25b36c44d8912b7a0345.tar.bz2
gentoo-2-871b93fb6e87f2448b2d25b36c44d8912b7a0345.zip
Version bump by Vladimir Ivanov <v.ivanov@ymail.com>, bug #354689, with improvements by me
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/core/ChangeLog11
-rw-r--r--dev-ml/core/core-0.7.0_beta1.ebuild53
-rw-r--r--dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch27
3 files changed, 89 insertions, 2 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 91a04b707a34..2cf4e3c9a72b 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ml/core
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.2 2010/11/11 20:09:18 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.3 2011/02/24 20:12:10 aballier Exp $
+
+*core-0.7.0_beta1 (24 Feb 2011)
+
+ 24 Feb 2011; Alexis Ballier <aballier@gentoo.org> +core-0.7.0_beta1.ebuild,
+ +files/core-0.7.0_beta1-ocaml312.patch:
+ Version bump by Vladimir Ivanov <v.ivanov@ymail.com>, bug #354689, with
+ improvements by me
11 Nov 2010; Alexis Ballier <aballier@gentoo.org> core-0.6.0.ebuild,
+files/core-0.6.0-ocaml312.patch:
diff --git a/dev-ml/core/core-0.7.0_beta1.ebuild b/dev-ml/core/core-0.7.0_beta1.ebuild
new file mode 100644
index 000000000000..3fde16a3b04d
--- /dev/null
+++ b/dev-ml/core/core-0.7.0_beta1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.7.0_beta1.ebuild,v 1.1 2011/02/24 20:12:10 aballier Exp $
+
+EAPI="2"
+inherit findlib eutils multilib
+
+MY_P=${P/_/\~}
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://www.janestreet.com/ocaml/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug +ocamlopt test"
+
+RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ dev-ml/res
+ >=dev-ml/sexplib-5.2.0
+ dev-ml/bin-prot
+ dev-ml/fieldslib"
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 )"
+
+S=${WORKDIR}/${PN}
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_prepare() {
+ has_version '>=dev-lang/ocaml-3.12' && epatch "${FILESDIR}/${P}-ocaml312.patch"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+ dodoc README || die
+}
diff --git a/dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch b/dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch
new file mode 100644
index 000000000000..56dae5b0c4ea
--- /dev/null
+++ b/dev-ml/core/files/core-0.7.0_beta1-ocaml312.patch
@@ -0,0 +1,27 @@
+diff -cr lib.orig/core_gc.ml lib/core_gc.ml
+*** lib.orig/core_gc.ml Sat Dec 11 00:11:49 2010
+--- lib/core_gc.ml Sat Feb 19 12:19:33 2011
+***************
+*** 86,91 ****
+--- 86,92 ----
+ fragments : int;
+ compactions : int;
+ top_heap_words : int;
++ stack_size : int;
+ } with bin_io, sexp
+ type binable = t
+ type sexpable = t
+diff -cr lib.orig/core_gc.mli lib/core_gc.mli
+*** lib.orig/core_gc.mli Sat Dec 11 00:11:49 2010
+--- lib/core_gc.mli Sat Feb 19 12:19:55 2011
+***************
+*** 103,108 ****
+--- 103,110 ----
+
+ top_heap_words : int;
+ (** Maximum size reached by the major heap, in words. *)
++
++ stack_size : int;
+ }
+ include Binable.S with type binable = t
+ include Sexpable.S with type sexpable = t