summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-14 08:45:01 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-14 08:45:01 +0000
commit9cc59b5f86ec2f92f4f70c86135a10eb20c2c9ca (patch)
tree425c814817a24e87eda40f41a844648670432032 /dev-ml
parentVersion bump. Removed old (diff)
downloadgentoo-2-9cc59b5f86ec2f92f4f70c86135a10eb20c2c9ca.tar.gz
gentoo-2-9cc59b5f86ec2f92f4f70c86135a10eb20c2c9ca.tar.bz2
gentoo-2-9cc59b5f86ec2f92f4f70c86135a10eb20c2c9ca.zip
Fix bashisms in configure, bug #553596 by Rémi Cardona.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/parmap/ChangeLog6
-rw-r--r--dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch12
-rw-r--r--dev-ml/parmap/parmap-1.0_rc6.ebuild12
3 files changed, 26 insertions, 4 deletions
diff --git a/dev-ml/parmap/ChangeLog b/dev-ml/parmap/ChangeLog
index 76a7c11d2be9..1930cc859be4 100644
--- a/dev-ml/parmap/ChangeLog
+++ b/dev-ml/parmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/parmap
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/parmap/ChangeLog,v 1.6 2015/07/14 08:31:01 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/parmap/ChangeLog,v 1.7 2015/07/14 08:45:01 aballier Exp $
+
+ 14 Jul 2015; Alexis Ballier <aballier@gentoo.org> parmap-1.0_rc6.ebuild,
+ +files/parmap-1.0_rc6-fix-bashisms.patch:
+ Fix bashisms in configure, bug #553596 by Rémi Cardona.
14 Jul 2015; Alexis Ballier <aballier@gentoo.org> -parmap-1.0_rc5.ebuild:
remove old
diff --git a/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch b/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch
new file mode 100644
index 000000000000..daba08c649fe
--- /dev/null
+++ b/dev-ml/parmap/files/parmap-1.0_rc6-fix-bashisms.patch
@@ -0,0 +1,12 @@
+--- configure.ac 2015-07-03 23:59:19.361723234 +0200
++++ configure.ac 2015-07-03 23:59:48.161216749 +0200
+@@ -27,7 +27,7 @@
+ AC_CONFIG_HEADERS([config.h])
+
+-t=`$OCAMLBUILD -use-ocamlfind &> /dev/null; echo $?`
+-if test $t == 0 ; then
++t=`$OCAMLBUILD -use-ocamlfind > /dev/null 2>&1 ; echo $?`
++if test "$t" = 0 ; then
+ AC_MSG_RESULT(ocaml version $OCAMLVERSION. Use standard Makefile)
+ AC_CONFIG_FILES([Makefile])
+ AC_OUTPUT
diff --git a/dev-ml/parmap/parmap-1.0_rc6.ebuild b/dev-ml/parmap/parmap-1.0_rc6.ebuild
index ec43c6fd051f..bd18a858f66d 100644
--- a/dev-ml/parmap/parmap-1.0_rc6.ebuild
+++ b/dev-ml/parmap/parmap-1.0_rc6.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/parmap/parmap-1.0_rc6.ebuild,v 1.2 2015/07/08 05:49:29 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/parmap/parmap-1.0_rc6.ebuild,v 1.3 2015/07/14 08:45:01 aballier Exp $
EAPI=5
-inherit multilib
+inherit multilib eutils autotools
MY_PV="${PV/_/-}"
DESCRIPTION="Library allowing to exploit multicore architectures for OCaml programs with minimal modifications"
@@ -18,9 +18,15 @@ IUSE="+ocamlopt"
RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
DEPEND="${RDEPEND}
- dev-ml/findlib"
+ dev-ml/findlib
+ dev-ml/ocaml-autoconf"
S="${WORKDIR}/${PN}-${MY_PV}"
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-bashisms.patch"
+ eautoreconf
+}
+
src_test() {
mkdir "${WORKDIR}/tmpinstall" || die
emake \