summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-11 20:09:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-11 20:09:18 +0000
commiteef387e90bf2ffc8d0db64ad45fe2bfee12685ba (patch)
treef97d264c132d9330216f9545c2f49f128c9b3348 /dev-ml
parentMentioned app-portage/flaggie as an alternative to masked app-portage/flagedit. (diff)
downloadgentoo-2-eef387e90bf2ffc8d0db64ad45fe2bfee12685ba.tar.gz
gentoo-2-eef387e90bf2ffc8d0db64ad45fe2bfee12685ba.tar.bz2
gentoo-2-eef387e90bf2ffc8d0db64ad45fe2bfee12685ba.zip
Import a patch from debian to fix build with ocaml 3.12, bug #343811
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/core/ChangeLog8
-rw-r--r--dev-ml/core/core-0.6.0.ebuild10
-rw-r--r--dev-ml/core/files/core-0.6.0-ocaml312.patch22
3 files changed, 35 insertions, 5 deletions
diff --git a/dev-ml/core/ChangeLog b/dev-ml/core/ChangeLog
index 563147e11016..91a04b707a34 100644
--- a/dev-ml/core/ChangeLog
+++ b/dev-ml/core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/core
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.1 2009/10/27 12:36:35 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/ChangeLog,v 1.2 2010/11/11 20:09:18 aballier Exp $
+
+ 11 Nov 2010; Alexis Ballier <aballier@gentoo.org> core-0.6.0.ebuild,
+ +files/core-0.6.0-ocaml312.patch:
+ Import a patch from debian to fix build with ocaml 3.12, bug #343811
*core-0.6.0 (27 Oct 2009)
diff --git a/dev-ml/core/core-0.6.0.ebuild b/dev-ml/core/core-0.6.0.ebuild
index 7dede9f282df..b2a094a5eb2a 100644
--- a/dev-ml/core/core-0.6.0.ebuild
+++ b/dev-ml/core/core-0.6.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.6.0.ebuild,v 1.1 2009/10/27 12:36:35 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/core/core-0.6.0.ebuild,v 1.2 2010/11/11 20:09:18 aballier Exp $
EAPI="2"
-inherit findlib
+inherit findlib eutils
DESCRIPTION="Jane Street's alternative to the standard library"
HOMEPAGE="http://www.janestreet.com/ocaml"
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
dev-ml/type-conv
)"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-3.12' && epatch "${FILESDIR}/${P}-ocaml312.patch"
+}
+
src_compile() {
emake -j1 || die
}
diff --git a/dev-ml/core/files/core-0.6.0-ocaml312.patch b/dev-ml/core/files/core-0.6.0-ocaml312.patch
new file mode 100644
index 000000000000..9ed10d1eb1ea
--- /dev/null
+++ b/dev-ml/core/files/core-0.6.0-ocaml312.patch
@@ -0,0 +1,22 @@
+--- janest-core-0.6.0.orig/lib/core_gc.mli
++++ janest-core-0.6.0/lib/core_gc.mli
+@@ -71,6 +71,8 @@
+
+ top_heap_words : int;
+ (** Maximum size reached by the major heap, in words. *)
++
++ stack_size : int;
+ }
+ include Binable.S with type binable = t
+ include Sexpable.S with type sexpable = t
+--- janest-core-0.6.0.orig/lib/core_gc.ml
++++ janest-core-0.6.0/lib/core_gc.ml
+@@ -54,6 +54,7 @@
+ fragments : pretty_int;
+ compactions : pretty_int;
+ top_heap_words : pretty_int;
++ stack_size : pretty_int;
+ } with bin_io, sexp
+ type binable = t
+ type sexpable = t
+