summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-25 19:43:21 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2014-10-25 19:43:21 +0000
commit635b374cb818630e677d40106bb382ca4d6ad88d (patch)
tree6e3904533f0ea31c4145adf620185adaa4babb21 /dev-perl/Const-Fast
parentUnmask pinpoint (#508854#c58 by Ferenc Erki) (diff)
downloadgentoo-2-635b374cb818630e677d40106bb382ca4d6ad88d.tar.gz
gentoo-2-635b374cb818630e677d40106bb382ca4d6ad88d.tar.bz2
gentoo-2-635b374cb818630e677d40106bb382ca4d6ad88d.zip
Fix dependencies, bug 518644
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key EBE6A336BE19039C!)
Diffstat (limited to 'dev-perl/Const-Fast')
-rw-r--r--dev-perl/Const-Fast/ChangeLog8
-rw-r--r--dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-perl/Const-Fast/ChangeLog b/dev-perl/Const-Fast/ChangeLog
index f6f419199591..27ef8fbcccbc 100644
--- a/dev-perl/Const-Fast/ChangeLog
+++ b/dev-perl/Const-Fast/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Const-Fast
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Const-Fast/ChangeLog,v 1.11 2014/07/30 21:22:40 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Const-Fast/ChangeLog,v 1.12 2014/10/25 19:43:21 dilfridge Exp $
+
+*Const-Fast-0.14.0-r1 (25 Oct 2014)
+
+ 25 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org>
+ +Const-Fast-0.14.0-r1.ebuild:
+ Fix dependencies, bug 518644
*Const-Fast-0.14.0 (30 Jul 2014)
diff --git a/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild b/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
new file mode 100644
index 000000000000..fb6564d07705
--- /dev/null
+++ b/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Const-Fast/Const-Fast-0.14.0-r1.ebuild,v 1.1 2014/10/25 19:43:21 dilfridge Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=LEONT
+MODULE_VERSION=0.014
+inherit perl-module
+
+DESCRIPTION="Facility for creating read-only scalars, arrays, and hashes"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Storable
+ >=dev-perl/Sub-Exporter-Progressive-0.1.7
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-Tiny-0.21.0
+ test? (
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ dev-perl/Test-Fatal
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+SRC_TEST=do
+mytargets="install"