summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-12-18 03:23:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-12-18 03:23:14 +0000
commit25f9d6e3f5f7c11ededab3d5bdd805d51aa8170e (patch)
treebc0eec14e394439e5e1202ce8462509f1f82dc64 /dev-perl/DBD-Pg
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-25f9d6e3f5f7c11ededab3d5bdd805d51aa8170e.tar.gz
gentoo-2-25f9d6e3f5f7c11ededab3d5bdd805d51aa8170e.tar.bz2
gentoo-2-25f9d6e3f5f7c11ededab3d5bdd805d51aa8170e.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog7
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.16.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index a66a54d1189d..810e78e0e91a 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.72 2009/10/19 09:06:25 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.73 2009/12/18 03:23:14 robbat2 Exp $
+
+*DBD-Pg-2.16.0 (18 Dec 2009)
+
+ 18 Dec 2009; Robin H. Johnson <robbat2@gentoo.org> +DBD-Pg-2.16.0.ebuild:
+ Version bump via perl-bump experimental tool.
19 Oct 2009; Torsten Veller <tove@gentoo.org> -DBD-Pg-1.49.ebuild:
Cleanup
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.16.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.16.0.ebuild
new file mode 100644
index 000000000000..fd3fccdedd47
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.16.0.ebuild,v 1.1 2009/12/18 03:23:14 robbat2 Exp $
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module eutils
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/perl-Test-Simple
+ virtual/perl-version
+ >=virtual/perl-Test-Harness-2.03
+ >=dev-perl/DBI-1.52
+ >=virtual/postgresql-base-7.3"
+
+mydoc="README"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_compile() {
+ postgres_include="$(readlink -f /usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d ${postgres_lib}/${i} ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_compile
+}