summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-01-09 19:15:57 +0000
committerFabian Groffen <grobian@gentoo.org>2010-01-09 19:15:57 +0000
commit8bc8d176a2704a3393fc359ba1f28b02a18e8ce5 (patch)
tree6eb578cae6d81ee6a7fefe31db6a5ee0afd9078e /dev-perl/DBD-Pg
parentRemove old. (diff)
downloadgentoo-2-8bc8d176a2704a3393fc359ba1f28b02a18e8ce5.tar.gz
gentoo-2-8bc8d176a2704a3393fc359ba1f28b02a18e8ce5.tar.bz2
gentoo-2-8bc8d176a2704a3393fc359ba1f28b02a18e8ce5.zip
Revision bump for Prefix fix and transfer of Prefix keywords, bug #294758
(Portage version: 2.2.00.15184-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog9
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.16.0-r1.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index 810e78e0e91a..d923abefc1fc 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.73 2009/12/18 03:23:14 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.74 2010/01/09 19:15:57 grobian Exp $
+
+*DBD-Pg-2.16.0-r1 (09 Jan 2010)
+
+ 09 Jan 2010; Fabian Groffen <grobian@gentoo.org> +DBD-Pg-2.16.0-r1.ebuild:
+ Revision bump for Prefix fix and transfer of Prefix keywords, bug #294758
*DBD-Pg-2.16.0 (18 Dec 2009)
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.16.0-r1.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.16.0-r1.ebuild
new file mode 100644
index 000000000000..12e7d84eca29
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.16.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.16.0-r1.ebuild,v 1.1 2010/01/09 19:15:57 grobian Exp $
+
+MODULE_AUTHOR=TURNSTEP
+inherit perl-module eutils
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND="virtual/perl-Test-Simple
+ virtual/perl-version
+ >=virtual/perl-Test-Harness-2.03
+ >=dev-perl/DBI-1.52
+ >=virtual/postgresql-base-7.3"
+
+mydoc="README"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_compile() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d ${postgres_lib}/${i} ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_compile
+}