summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-03-10 09:12:17 +0000
committerTorsten Veller <tove@gentoo.org>2012-03-10 09:12:17 +0000
commite2c5c0d6138db7481b6e46d3d51511784f93d272 (patch)
treebebc176a5d9c38566f96ea4580b031b34968c52f /dev-perl/DBD-Pg
parentVersion BUmp, #407539 (diff)
downloadgentoo-2-e2c5c0d6138db7481b6e46d3d51511784f93d272.tar.gz
gentoo-2-e2c5c0d6138db7481b6e46d3d51511784f93d272.tar.bz2
gentoo-2-e2c5c0d6138db7481b6e46d3d51511784f93d272.zip
[bump] dev-perl/DBD-Pg-2.19.0
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/DBD-Pg')
-rw-r--r--dev-perl/DBD-Pg/ChangeLog7
-rw-r--r--dev-perl/DBD-Pg/DBD-Pg-2.19.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-perl/DBD-Pg/ChangeLog b/dev-perl/DBD-Pg/ChangeLog
index 2a835e6be42b..7dd2a013a20b 100644
--- a/dev-perl/DBD-Pg/ChangeLog
+++ b/dev-perl/DBD-Pg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-Pg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.103 2012/03/02 21:33:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/ChangeLog,v 1.104 2012/03/10 09:12:17 tove Exp $
+
+*DBD-Pg-2.19.0 (10 Mar 2012)
+
+ 10 Mar 2012; Torsten Veller <tove@gentoo.org> +DBD-Pg-2.19.0.ebuild:
+ Version bump
02 Mar 2012; Brent Baude <ranger@gentoo.org> DBD-Pg-2.18.1.ebuild:
Marking DBD-Pg-2.18.1 ppc64 for bug 396921
diff --git a/dev-perl/DBD-Pg/DBD-Pg-2.19.0.ebuild b/dev-perl/DBD-Pg/DBD-Pg-2.19.0.ebuild
new file mode 100644
index 000000000000..506bce61365c
--- /dev/null
+++ b/dev-perl/DBD-Pg/DBD-Pg-2.19.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-Pg/DBD-Pg-2.19.0.ebuild,v 1.1 2012/03/10 09:12:17 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=TURNSTEP
+MODULE_VERSION=2.19.0
+inherit perl-module
+
+DESCRIPTION="The Perl DBD::Pg Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND="virtual/perl-version
+ >=dev-perl/DBI-1.52
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}"
+
+# testcases require a local database with an
+# open password for the postgres user.
+SRC_TEST="skip"
+
+src_prepare() {
+ postgres_include="$(readlink -f "${EPREFIX}"/usr/include/postgresql)"
+ postgres_lib="${postgres_include//include/lib}"
+ # Fall-through case is the non-split postgresql
+ # The active cases instead get us the matching libdir for the includedir.
+ for i in lib lib64 ; do
+ if [ -d "${postgres_lib}/${i}" ]; then
+ postgres_lib="${postgres_lib}/${i}"
+ break
+ fi
+ done
+
+ # env variables for compilation:
+ export POSTGRES_INCLUDE="${postgres_include}"
+ export POSTGRES_LIB="${postgres_lib}"
+ perl-module_src_prepare
+}