summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-03-09 14:56:36 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-03-09 14:56:36 +0000
commitdb44c0d5ccb20e99755d654abe8422e7621e986e (patch)
treef25095dc61f8bcfd821fd71d979d92553d218bec /dev-perl/DBD-mysql
parentRaise minimum xorg-server dependency, bug #540822. (diff)
downloadgentoo-2-db44c0d5ccb20e99755d654abe8422e7621e986e.tar.gz
gentoo-2-db44c0d5ccb20e99755d654abe8422e7621e986e.tar.bz2
gentoo-2-db44c0d5ccb20e99755d654abe8422e7621e986e.zip
Version bump. Fix bug 420245.
(Portage version: 2.2.14/cvs/Linux i686, unsigned Manifest commit)
Diffstat (limited to 'dev-perl/DBD-mysql')
-rw-r--r--dev-perl/DBD-mysql/ChangeLog9
-rw-r--r--dev-perl/DBD-mysql/DBD-mysql-4.31.0.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/dev-perl/DBD-mysql/ChangeLog b/dev-perl/DBD-mysql/ChangeLog
index ef822274bc12..f3ce959a45a4 100644
--- a/dev-perl/DBD-mysql/ChangeLog
+++ b/dev-perl/DBD-mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/DBD-mysql
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-mysql/ChangeLog,v 1.142 2014/08/20 20:27:28 axs Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-mysql/ChangeLog,v 1.143 2015/03/09 14:56:36 monsieurp Exp $
+
+*DBD-mysql-4.31.0 (09 Mar 2015)
+
+ 09 Mar 2015; Patrice Clement <monsieurp@gentoo.org> +DBD-mysql-4.31.0.ebuild:
+ Version bump. Fix bug 420245.
*DBD-mysql-4.20.0-r1 (20 Aug 2014)
diff --git a/dev-perl/DBD-mysql/DBD-mysql-4.31.0.ebuild b/dev-perl/DBD-mysql/DBD-mysql-4.31.0.ebuild
new file mode 100644
index 000000000000..8fec70bb6c51
--- /dev/null
+++ b/dev-perl/DBD-mysql/DBD-mysql-4.31.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-mysql/DBD-mysql-4.31.0.ebuild,v 1.1 2015/03/09 14:56:36 monsieurp Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=CAPTTOFU
+MODULE_VERSION=4.031
+inherit eutils perl-module
+
+DESCRIPTION="The Perl DBD:mysql Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="embedded test"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/Test-Deep
+ virtual/mysql[embedded?]"
+DEPEND="${RDEPEND}"
+
+if use test; then
+ SRC_TEST="do"
+else
+ SRC_TEST="skip"
+fi
+
+src_configure() {
+ if use test; then
+ myconf="${myconf} --testdb=test \
+ --testhost=localhost \
+ --testuser=test \
+ --testpassword=test"
+ fi
+ use embedded && myconf="${myconf} --force-embedded --embedded=mysql_config"
+ perl-module_src_configure
+}
+
+src_test() {
+ if use test; then
+ einfo
+ einfo "If tests fail, you have to configure your MySQL instance to create"
+ einfo "and grant some privileges to the test user."
+ einfo "You can run the following commands at the MySQL prompt: "
+ einfo "> CREATE USER 'test'@'localhost' IDENTIFIED BY 'test';"
+ einfo "> CREATE DATABASE test;"
+ einfo "> GRANT ALL PRIVILEGES ON test.* TO 'test'@'localhost';"
+ einfo
+ sleep 5
+ perl-module_src_test
+ fi
+}