summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2010-05-02 21:58:06 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2010-05-02 21:58:06 +0000
commitef2c18e566ad660e7d3e6ed3bdc70f973de4d1e2 (patch)
treee1c4dca9162e9bd54175411fcaeea21426f3da01 /dev-perl/DateManip/DateManip-6.11.ebuild
parentBug #317209: Version bump. (diff)
downloadgentoo-2-ef2c18e566ad660e7d3e6ed3bdc70f973de4d1e2.tar.gz
gentoo-2-ef2c18e566ad660e7d3e6ed3bdc70f973de4d1e2.tar.bz2
gentoo-2-ef2c18e566ad660e7d3e6ed3bdc70f973de4d1e2.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/DateManip/DateManip-6.11.ebuild')
-rw-r--r--dev-perl/DateManip/DateManip-6.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/DateManip/DateManip-6.11.ebuild b/dev-perl/DateManip/DateManip-6.11.ebuild
new file mode 100644
index 000000000000..5fa042d5b18a
--- /dev/null
+++ b/dev-perl/DateManip/DateManip-6.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DateManip/DateManip-6.11.ebuild,v 1.1 2010/05/02 21:58:06 robbat2 Exp $
+
+EAPI=2
+
+MY_PN=Date-Manip
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+MODULE_AUTHOR=SBECK
+inherit perl-module
+
+DESCRIPTION="Perl date manipulation routines"
+
+SLOT="0"
+# Temporarily dropped pending bug #318219
+KEYWORDS="~amd64 ~x86" #~ppc-aix ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE="test"
+
+# WARNING, the 6.x tarballs DO also include the 5.x version, and the build
+# system actually installs the 5.x version if you have perl 5.8!
+RDEPEND=">=dev-lang/perl-5.10
+ dev-perl/YAML-Syck
+ virtual/perl-Storable"
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build
+ dev-perl/Test-Inter
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage )"
+
+SRC_TEST="do"
+
+mydoc="HISTORY TODO README.first"