summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-12-31 17:03:55 +0000
committerTorsten Veller <tove@gentoo.org>2008-12-31 17:03:55 +0000
commit75c843754849fb575e2b9e60f41a9f61b2b2c96c (patch)
tree3a4bc98a950cdc7ee972f84caf6bb2d88935d4d3 /dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild
parentVersion bump (diff)
downloadgentoo-2-75c843754849fb575e2b9e60f41a9f61b2b2c96c.tar.gz
gentoo-2-75c843754849fb575e2b9e60f41a9f61b2b2c96c.tar.bz2
gentoo-2-75c843754849fb575e2b9e60f41a9f61b2b2c96c.zip
Version bump
(Portage version: 2.2_rc20/cvs/Linux 2.6.27-tuxonice i686)
Diffstat (limited to 'dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild')
-rw-r--r--dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild b/dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild
new file mode 100644
index 000000000000..7a4579f1ec6a
--- /dev/null
+++ b/dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Email-Abstract/Email-Abstract-3.001.ebuild,v 1.1 2008/12/31 17:03:55 tove Exp $
+
+inherit versionator
+
+MY_P="${PN}-$(delete_version_separator 2)"
+S=${WORKDIR}/${MY_P}
+MODULE_AUTHOR=RJBS
+
+inherit perl-module
+
+DESCRIPTION="unified interface to mail representations"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND=">=virtual/perl-Class-ISA-0.20
+ >=dev-perl/Email-Simple-1.91
+ >=virtual/perl-Module-Pluggable-1.5
+ virtual/perl-Scalar-List-Utils
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ test? ( virtual/perl-Test-Simple
+ >=dev-perl/Test-Pod-1.14
+ >=dev-perl/Test-Pod-Coverage-1.08 )"
+
+SRC_TEST="do"