summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-12-08 03:21:22 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-12-08 03:21:22 +0000
commit6b3ecdde758095d40aeedda4d38051c1593cfd1e (patch)
tree621a0d76c8c9ab7f7771a04b4778e96fe3877582 /dev-perl/Inline
parentRemoving wltjr as a maintainer since he was retired. (diff)
downloadgentoo-2-6b3ecdde758095d40aeedda4d38051c1593cfd1e.tar.gz
gentoo-2-6b3ecdde758095d40aeedda4d38051c1593cfd1e.tar.bz2
gentoo-2-6b3ecdde758095d40aeedda4d38051c1593cfd1e.zip
Version bump.
(Portage version: 2.2_rc16/cvs/Linux 2.6.28-rc5-00117-g7f0f598 x86_64)
Diffstat (limited to 'dev-perl/Inline')
-rw-r--r--dev-perl/Inline/ChangeLog9
-rw-r--r--dev-perl/Inline/Inline-0.45.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/dev-perl/Inline/ChangeLog b/dev-perl/Inline/ChangeLog
index 015505525e38..455b2ffbaca8 100644
--- a/dev-perl/Inline/ChangeLog
+++ b/dev-perl/Inline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Inline
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/ChangeLog,v 1.33 2007/05/01 10:06:16 corsair Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/ChangeLog,v 1.34 2008/12/08 03:21:22 robbat2 Exp $
+
+*Inline-0.45 (08 Dec 2008)
+
+ 08 Dec 2008; Robin H. Johnson <robbat2@gentoo.org> +Inline-0.45.ebuild:
+ Version bump.
01 May 2007; Markus Rothe <corsair@gentoo.org> Inline-0.44-r1.ebuild:
Stable on ppc64; bug #175120
diff --git a/dev-perl/Inline/Inline-0.45.ebuild b/dev-perl/Inline/Inline-0.45.ebuild
new file mode 100644
index 000000000000..1d265adee9c3
--- /dev/null
+++ b/dev-perl/Inline/Inline-0.45.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline/Inline-0.45.ebuild,v 1.1 2008/12/08 03:21:22 robbat2 Exp $
+
+MODULE_AUTHOR=SISYPHUS
+inherit perl-module eutils
+
+DESCRIPTION="Write Perl subroutines in other languages"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="gtk"
+
+DEPEND="virtual/perl-Digest-MD5
+ virtual/perl-File-Spec
+ dev-perl/Parse-RecDescent
+ virtual/perl-Test-Harness
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}
+ #gtk-2 suggested patch
+ use gtk && epatch ${FILESDIR}/gtk2-patch.diff
+}
+
+src_compile() {
+ echo "y" | perl-module_src_compile
+ perl-module_src_test
+}
+
+src_install() {
+ perl-module_src_install
+ dohtml DT.html
+}