summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-12-25 12:39:42 +0000
committerTorsten Veller <tove@gentoo.org>2012-12-25 12:39:42 +0000
commitea9e72a8b0052292b883053cfb69f625c39f2ad0 (patch)
tree01cf72da408c4604141f29bda030eae994c57dcd /dev-perl/Net-DNS
parentDrop old (diff)
downloadgentoo-2-ea9e72a8b0052292b883053cfb69f625c39f2ad0.tar.gz
gentoo-2-ea9e72a8b0052292b883053cfb69f625c39f2ad0.tar.bz2
gentoo-2-ea9e72a8b0052292b883053cfb69f625c39f2ad0.zip
[bump] dev-perl/Net-DNS-0.710.0
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 0x5772769F4E046AEC)
Diffstat (limited to 'dev-perl/Net-DNS')
-rw-r--r--dev-perl/Net-DNS/ChangeLog7
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-perl/Net-DNS/ChangeLog b/dev-perl/Net-DNS/ChangeLog
index 66ef8cff3612..6a2e8abd3554 100644
--- a/dev-perl/Net-DNS/ChangeLog
+++ b/dev-perl/Net-DNS/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Net-DNS
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/ChangeLog,v 1.165 2012/12/08 11:10:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/ChangeLog,v 1.166 2012/12/25 12:39:42 tove Exp $
+
+*Net-DNS-0.710.0 (25 Dec 2012)
+
+ 25 Dec 2012; Torsten Veller <tove@gentoo.org> +Net-DNS-0.710.0.ebuild:
+ Version bump
*Net-DNS-0.700.0 (08 Dec 2012)
diff --git a/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild
new file mode 100644
index 000000000000..c916df97a36d
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.710.0.ebuild,v 1.1 2012/12/25 12:39:42 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=NLNETLABS
+MODULE_VERSION=0.71
+inherit perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6 test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-SHA
+ dev-perl/Net-IP
+ virtual/perl-MIME-Base64
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ )"
+
+PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+}