summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-06-16 15:57:39 +0000
committerTorsten Veller <tove@gentoo.org>2011-06-16 15:57:39 +0000
commitce9427186571bc2d15e2fb261b00e585af05a2b6 (patch)
treef15fb8793683375556f9f5af7c212f758cffe6c5 /dev-perl/Perlbal/Perlbal-1.790.0.ebuild
parentFix missing virtual/jpeg dep wrt #371879 by Markus Knetschke (diff)
downloadgentoo-2-ce9427186571bc2d15e2fb261b00e585af05a2b6.tar.gz
gentoo-2-ce9427186571bc2d15e2fb261b00e585af05a2b6.tar.bz2
gentoo-2-ce9427186571bc2d15e2fb261b00e585af05a2b6.zip
Fix MODULE_VERSION
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Perlbal/Perlbal-1.790.0.ebuild')
-rw-r--r--dev-perl/Perlbal/Perlbal-1.790.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Perlbal/Perlbal-1.790.0.ebuild b/dev-perl/Perlbal/Perlbal-1.790.0.ebuild
new file mode 100644
index 000000000000..5f7eece89b0d
--- /dev/null
+++ b/dev-perl/Perlbal/Perlbal-1.790.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Perlbal/Perlbal-1.790.0.ebuild,v 1.1 2011/06/16 15:57:39 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=DORMANDO
+MODULE_VERSION=1.79
+inherit perl-module
+
+DESCRIPTION="Reverse-proxy load balancer and webserver"
+HOMEPAGE="http://www.danga.com/perlbal/"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/libwww-perl
+ >=dev-perl/Danga-Socket-1.57
+ dev-perl/Sys-Syscall
+ dev-perl/BSD-Resource
+ dev-perl/IO-AIO"
+DEPEND="${RDEPEND}"
+#SRC_TEST="do" # testing not available on Perlbal yet ;-)
+
+PATCHES=( "${FILESDIR}/${PN}-1.58-Use-saner-name-in-process-listing.patch" )
+
+src_install() {
+ perl-module_src_install || die "perl-module_src_install failed"
+ cd "${S}"
+ dodoc doc/*.txt
+ docinto hacking
+ dodoc doc/hacking/*.txt
+ docinto conf
+ dodoc conf/*.{dat,conf}
+ keepdir /etc/perlbal
+ newinitd "${FILESDIR}"/perlbal_init.d_1.58 perlbal
+ newconfd "${FILESDIR}"/perlbal_conf.d_1.58 perlbal
+}
+
+pkg_postinst() {
+ einfo "Please see the example configuration files located"
+ einfo "within /usr/share/doc/${PF}/conf/"
+}