summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 00:48:47 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 00:48:47 +0000
commitb61f51858b05b5533c43475881e2cdcd669e5ebd (patch)
tree59813a0144b7a286ed7b832b8125df4598193b26 /dev-perl/SGMLSpm/files
parent*** empty log message *** (diff)
downloadgentoo-2-b61f51858b05b5533c43475881e2cdcd669e5ebd.tar.gz
gentoo-2-b61f51858b05b5533c43475881e2cdcd669e5ebd.tar.bz2
gentoo-2-b61f51858b05b5533c43475881e2cdcd669e5ebd.zip
Some cleanup
Diffstat (limited to 'dev-perl/SGMLSpm/files')
-rw-r--r--dev-perl/SGMLSpm/files/Makefile98
1 files changed, 0 insertions, 98 deletions
diff --git a/dev-perl/SGMLSpm/files/Makefile b/dev-perl/SGMLSpm/files/Makefile
deleted file mode 100644
index c9f53097ad16..000000000000
--- a/dev-perl/SGMLSpm/files/Makefile
+++ /dev/null
@@ -1,98 +0,0 @@
-########################################################################
-# Makefile for installing SGMLS.pm and associated files in Unix
-# or Unix-like environments. You should check the values of the
-# variables at the beginning and change them as appropriate.
-#
-# Version: 1.03ii
-########################################################################
-
-DIST = SGMLSpm-1.03ii.tar.gz
-
-#
-# Beginning of user options.
-#
-
-# Where is the binary for perl5 located on your system?
-PERL = /usr/bin/perl
-
-# Where do you want the sgmlspl executable script to be installed?
-BINDIR = ${D}/usr/bin
-
-# Where do you put local perl5 libaries?
-PERL5DIR = ${D}/usr/lib/perl5
-MODULEDIR = ${PERL5DIR}/site_perl/5.6.0/SGMLS
-
-# Where do you want to put sgmlspl specifications?
-SPECDIR = ${PERL5DIR}
-
-# If you plan to install the HTML version of the documentation, where
-# do you intend to put it? 'make html' will create two
-# subdirectories, ${HTMLDIR}/SGMLSpm and ${HTMLDIR}/sgmlspl, and place
-# its files there.
-HTMLDIR = ${D}/usr/doc/${P}/html
-
-
-#
-# End of user options.
-#
-
-HTML_SOURCES = DOC/HTML/SGMLSpm/ DOC/HTML/sgmlspl/
-
-FILES = ${BINDIR}/sgmlspl \
- ${PERL5DIR}/SGMLS.pm \
- ${MODULEDIR}/Output.pm \
- ${MODULEDIR}/Refs.pm \
- ${SPECDIR}/skel.pl
-
-all: install docs
-
-install: install_system # install_html
-
-install_system: ${MODULEDIR} ${FILES}
-
-dist: ${DIST}
-
-${BINDIR}/sgmlspl: sgmlspl.pl
- sed -e 's!/usr/bin/perl!${PERL}!' sgmlspl.pl > ${BINDIR}/sgmlspl
- chmod a+x,a+r ${BINDIR}/sgmlspl
-
-${PERL5DIR}/SGMLS.pm: SGMLS.pm
- cp SGMLS.pm ${PERL5DIR}/SGMLS.pm
- chmod a+r ${PERL5DIR}/SGMLS.pm
-
-${MODULEDIR}:
- if [ ! -d ${MODULEDIR} ]; then\
- mkdir ${MODULEDIR}; \
- chmod a+x ${MODULEDIR}; \
- fi
-
-${MODULEDIR}/Output.pm: Output.pm
- cp Output.pm ${MODULEDIR}/Output.pm
- chmod a+r ${MODULEDIR}/Output.pm
-
-${MODULEDIR}/Refs.pm: Refs.pm
- cp Refs.pm ${MODULEDIR}/Refs.pm
- chmod a+r ${MODULEDIR}/Refs.pm
-
-${SPECDIR}/skel.pl: skel.pl
- cp skel.pl ${SPECDIR}/skel.pl
- chmod a+r ${SPECDIR}/skel.pl
-
-install_html: ${HTML_SOURCES}
- cd DOC; make html
- rm -rf ${HTMLDIR}/SGMLSpm ${HTMLDIR}/sgmlspl
- cp -r ${HTML_SOURCES} ${HTMLDIR}
- chmod a+x,a+r ${HTMLDIR}/SGMLSpm ${HTMLDIR}/sgmlspl
- chmod a+r ${HTMLDIR}/SGMLSpm/* ${HTMLDIR}/sgmlspl/*
-
-docs:
- cd DOC; make all
-
-${DIST}: clean docs
- cd ..; \
- tar -c -v -z --exclude RCS -f /tmp/${DIST} SGMLSpm; \
- mv /tmp/${DIST} SGMLSpm
-
-clean:
- cd DOC; make clean
- rm -f *~ core *.tar *.tar.gz