summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-05 20:06:23 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-12-05 20:06:23 +0000
commit1d3dc219a36aa2986fc48ebc32e2feca6a925897 (patch)
tree19260b1fe111af563e22fba23f62d7204dda48b4 /dev-perl/Search-Xapian
parentVersion bump 1.2.{15,16}. Disable mono bindings since it violates sandbox. (diff)
downloadgentoo-2-1d3dc219a36aa2986fc48ebc32e2feca6a925897.tar.gz
gentoo-2-1d3dc219a36aa2986fc48ebc32e2feca6a925897.tar.bz2
gentoo-2-1d3dc219a36aa2986fc48ebc32e2feca6a925897.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'dev-perl/Search-Xapian')
-rw-r--r--dev-perl/Search-Xapian/ChangeLog8
-rw-r--r--dev-perl/Search-Xapian/Search-Xapian-1.2.16.0.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-perl/Search-Xapian/ChangeLog b/dev-perl/Search-Xapian/ChangeLog
index 67004f003562..4f4df13c7eec 100644
--- a/dev-perl/Search-Xapian/ChangeLog
+++ b/dev-perl/Search-Xapian/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/Search-Xapian
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/ChangeLog,v 1.37 2013/11/24 18:39:19 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/ChangeLog,v 1.38 2013/12/05 20:06:23 blueness Exp $
+
+*Search-Xapian-1.2.16.0 (05 Dec 2013)
+
+ 05 Dec 2013; Anthony G. Basile <blueness@gentoo.org>
+ +Search-Xapian-1.2.16.0.ebuild:
+ Version bump
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> Search-Xapian-1.2.14.0.ebuild:
Stable for sparc, wrt bug #470402
diff --git a/dev-perl/Search-Xapian/Search-Xapian-1.2.16.0.ebuild b/dev-perl/Search-Xapian/Search-Xapian-1.2.16.0.ebuild
new file mode 100644
index 000000000000..1340e317ae00
--- /dev/null
+++ b/dev-perl/Search-Xapian/Search-Xapian-1.2.16.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Search-Xapian/Search-Xapian-1.2.16.0.ebuild,v 1.1 2013/12/05 20:06:23 blueness Exp $
+
+EAPI="5"
+
+MODULE_AUTHOR=OLLY
+inherit perl-module toolchain-funcs versionator
+
+VERSION=$(get_version_component_range 1-3)
+
+SRC_URI+=" http://oligarchy.co.uk/xapian/${VERSION}/${P}.tar.gz"
+DESCRIPTION="Perl XS frontend to the Xapian C++ search library."
+
+LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="~dev-libs/xapian-${VERSION}
+ !dev-libs/xapian-bindings[perl]"
+DEPEND="${RDEPEND}
+ virtual/perl-Module-Build"
+
+SRC_TEST="do"
+
+myconf="CXX=$(tc-getCXX) CXXFLAGS=${CXXFLAGS}"
+
+src_install() {
+ perl-module_src_install
+
+ use examples && {
+ docinto examples
+ dodoc "${S}"/examples/*
+ }
+}