summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-09-03 03:08:04 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-09-03 03:08:04 +0000
commit0d863ff2e00b9ba586b89180e016b2023f3dfba8 (patch)
treef2de0ff4b34317fe07bf7020054f6a26a4674436 /dev-perl/WWW-Mechanize
parentVersion bump. (diff)
downloadgentoo-2-0d863ff2e00b9ba586b89180e016b2023f3dfba8.tar.gz
gentoo-2-0d863ff2e00b9ba586b89180e016b2023f3dfba8.tar.bz2
gentoo-2-0d863ff2e00b9ba586b89180e016b2023f3dfba8.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-perl/WWW-Mechanize')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.730.0.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 4fbfd64b142f..63b060e0efa8 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.90 2013/02/20 23:31:00 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.91 2013/09/03 03:08:04 patrick Exp $
+
+*WWW-Mechanize-1.730.0 (03 Sep 2013)
+
+ 03 Sep 2013; Patrick Lauer <patrick@gentoo.org> +WWW-Mechanize-1.730.0.ebuild:
+ Bump
20 Feb 2013; Zac Medico <zmedico@gentoo.org> WWW-Mechanize-1.720.0.ebuild:
Add ~arm-linux keyword.
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.730.0.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.730.0.ebuild
new file mode 100644
index 000000000000..ea4d18a22c32
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.730.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.730.0.ebuild,v 1.1 2013/09/03 03:08:04 patrick Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=ETHER
+MODULE_VERSION=1.73
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/IO-Socket-SSL
+ || (
+ ( >dev-perl/libwww-perl-6 dev-perl/HTML-Form )
+ <dev-perl/libwww-perl-6
+ )
+ >=dev-perl/URI-1.36
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/HTML-Tree
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-perl/PadWalker
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ dev-perl/Test-Exception
+ dev-perl/Test-NoWarnings
+ dev-perl/Test-Taint
+ >=dev-perl/Test-Warn-0.11
+ dev-perl/Test-Memory-Cycle
+ dev-perl/HTTP-Server-Simple
+ )
+"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+SRC_TEST=do