summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2003-09-08 11:21:31 +0000
committerMichael Cummings <mcummings@gentoo.org>2003-09-08 11:21:31 +0000
commit3612311ed375b82164a2aaba42c43ebf9e655bf4 (patch)
tree5c80a21dbf4035aeccb5f3b088680437c53d988d /dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild
parentnew version from sourceforge (diff)
downloadgentoo-2-3612311ed375b82164a2aaba42c43ebf9e655bf4.tar.gz
gentoo-2-3612311ed375b82164a2aaba42c43ebf9e655bf4.tar.bz2
gentoo-2-3612311ed375b82164a2aaba42c43ebf9e655bf4.zip
new version from sourceforge
Diffstat (limited to 'dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild')
-rw-r--r--dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild b/dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild
new file mode 100644
index 000000000000..7cb1b1e557d2
--- /dev/null
+++ b/dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/gtk2-spell/gtk2-spell-1.02.ebuild,v 1.1 2003/09/08 11:18:55 mcummings Exp $
+
+inherit perl-module
+
+MY_P=Gtk2-Spell-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Bindings for GtkSpell with Gtk2.x"
+SRC_URI="mirror://sourceforge/gtk2-perl/${MY_P}.tar.gz"
+HOMEPAGE="http://gtk2-perl.sf.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa"
+
+DEPEND="${DEPEND}
+ >=x11-libs/gtk+-2*
+ >=app-text/gtkspell-2*
+ >=dev-perl/glib-perl-0.26
+ >=dev-perl/gtk2-perl-0.26"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Without this it cannot find gtkspell <rigo@home.nl>
+ sed -ie "s:\#my:my:g" Makefile.PL || die "sed failed"
+}