summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2009-11-13 02:17:34 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2009-11-13 02:17:34 +0000
commit1dde0fb36b30edd2cec53bce1701c505b82d7074 (patch)
tree5da557f03813d6e8d005731be308665f60155f46 /dev-perl/math-pari
parentVersion bump via perl-bump experimental tool. (diff)
downloadgentoo-2-1dde0fb36b30edd2cec53bce1701c505b82d7074.tar.gz
gentoo-2-1dde0fb36b30edd2cec53bce1701c505b82d7074.tar.bz2
gentoo-2-1dde0fb36b30edd2cec53bce1701c505b82d7074.zip
Version bump via perl-bump experimental tool.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/math-pari')
-rw-r--r--dev-perl/math-pari/ChangeLog8
-rw-r--r--dev-perl/math-pari/math-pari-2.01080602.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-perl/math-pari/ChangeLog b/dev-perl/math-pari/ChangeLog
index 6228410e1b1f..83cf81afa59b 100644
--- a/dev-perl/math-pari/ChangeLog
+++ b/dev-perl/math-pari/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/math-pari
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.46 2009/11/11 09:47:05 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/ChangeLog,v 1.47 2009/11/13 02:17:34 robbat2 Exp $
+
+*math-pari-2.01080602 (13 Nov 2009)
+
+ 13 Nov 2009; Robin H. Johnson <robbat2@gentoo.org>
+ +math-pari-2.01080602.ebuild:
+ Version bump via perl-bump experimental tool.
11 Nov 2009; Torsten Veller <tove@gentoo.org>
-math-pari-2.010801-r1.ebuild:
diff --git a/dev-perl/math-pari/math-pari-2.01080602.ebuild b/dev-perl/math-pari/math-pari-2.01080602.ebuild
new file mode 100644
index 000000000000..df0bd7c4a82e
--- /dev/null
+++ b/dev-perl/math-pari/math-pari-2.01080602.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/math-pari/math-pari-2.01080602.ebuild,v 1.1 2009/11/13 02:17:34 robbat2 Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=ILYAZ
+MODULE_SECTION=modules
+MY_PN=Math-Pari
+MY_P=${MY_PN}-${PV}
+inherit perl-module
+
+PARI_VER=2.3.4
+
+DESCRIPTION="Perl interface to PARI"
+SRC_URI="${SRC_URI}
+ http://pari.math.u-bordeaux.fr/pub/pari/unix/pari-${PARI_VER}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+# Math::Pari requires that a copy of the pari source in a parallel
+# directory to where you build it. It does not need to compile it, but
+# it does need to be the same version as is installed, hence the hard
+# DEPEND below
+RDEPEND="~sci-mathematics/pari-${PARI_VER}"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+S_PARI=${WORKDIR}/pari-${PARI_VER}
+SRC_TEST=do
+
+src_prepare() {
+ # On 64-bit hardware, these files are needed in both the 64/ and 32/
+ # directories for the testsuite to pass.
+ cd "${S_PARI}"/src/test/
+ for t in analyz compat ellglobalred elliptic galois graph intnum kernel \
+ linear nfields number objets ploth polyser program qfbsolve rfrac \
+ round4 stark sumiter trans ; do
+ i="in/${t}"
+ o32="32/${t}"
+ o64="64/${t}"
+ [ -f "$i" -a ! -f "$o32" ] && cp -al "$i" "$o32"
+ [ -f "$i" -a ! -f "$o64" ] && cp -al "$i" "$o64"
+ done
+ perl-module_src_prepare
+}
+
+src_configure() {
+ # Unfortunately the assembly routines math-pari has for SPARC do not appear
+ # to be working at current. Perl cannot test math-pari or anything that
+ # pulls in the math-pari module as DynaLoader cannot load the resulting
+ # .so files math-pari generates. As such, we have to use the generic
+ # non-machine specific assembly methods here.
+ use sparc && myconf="${myconf} machine=none"
+
+ perl-module_src_configure
+}