summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-07-15 18:56:36 +0000
committerTorsten Veller <tove@gentoo.org>2012-07-15 18:56:36 +0000
commit4edc22fac48c713e2f3aad580cc5c4f428788b07 (patch)
tree9b62d3f5e7a137cb1b69d166d1714ebcd36ee18c /dev-perl
parentsparc stable wrt #410611 (diff)
downloadgentoo-2-4edc22fac48c713e2f3aad580cc5c4f428788b07.tar.gz
gentoo-2-4edc22fac48c713e2f3aad580cc5c4f428788b07.tar.bz2
gentoo-2-4edc22fac48c713e2f3aad580cc5c4f428788b07.zip
[bump] dev-perl/SOAP-Lite-0.715.0
(Portage version: 2.2.0_alpha118/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/SOAP-Lite/ChangeLog8
-rw-r--r--dev-perl/SOAP-Lite/SOAP-Lite-0.715.0.ebuild56
-rw-r--r--dev-perl/SOAP-Lite/metadata.xml2
3 files changed, 63 insertions, 3 deletions
diff --git a/dev-perl/SOAP-Lite/ChangeLog b/dev-perl/SOAP-Lite/ChangeLog
index 1f2c37269cb0..010b657430aa 100644
--- a/dev-perl/SOAP-Lite/ChangeLog
+++ b/dev-perl/SOAP-Lite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/SOAP-Lite
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.79 2012/06/24 12:59:16 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/ChangeLog,v 1.80 2012/07/15 18:56:36 tove Exp $
+
+*SOAP-Lite-0.715.0 (15 Jul 2012)
+
+ 15 Jul 2012; Torsten Veller <tove@gentoo.org> +SOAP-Lite-0.715.0.ebuild,
+ metadata.xml:
+ Version bump
24 Jun 2012; Torsten Veller <tove@gentoo.org> metadata.xml:
Update CPAN upstream info
diff --git a/dev-perl/SOAP-Lite/SOAP-Lite-0.715.0.ebuild b/dev-perl/SOAP-Lite/SOAP-Lite-0.715.0.ebuild
new file mode 100644
index 000000000000..ab1a29b27957
--- /dev/null
+++ b/dev-perl/SOAP-Lite/SOAP-Lite-0.715.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/SOAP-Lite/SOAP-Lite-0.715.0.ebuild,v 1.1 2012/07/15 18:56:36 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=MKUTTER
+MODULE_VERSION=0.715
+inherit perl-module eutils
+
+DESCRIPTION="Simple and lightweight interface to the SOAP protocol (sic) both on client and server side"
+
+IUSE="jabber ssl"
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+myconf="${myconf} --noprompt"
+
+# TESTS ARE DISABLED ON PURPOSE
+# This module attempts to access an external website for validation
+# of the MIME::Parser - not only is that bad practice in general,
+# but in this particular case the external site isn't even valid anymore# -mpc
+# 24/10/04
+SRC_TEST="do"
+
+DEPEND="
+ dev-perl/Class-Inspector
+ dev-perl/XML-Parser
+ dev-perl/libwww-perl
+ virtual/perl-libnet
+ dev-perl/MIME-Lite
+ virtual/perl-MIME-Base64
+ ssl? ( dev-perl/Crypt-SSLeay )
+ jabber? ( dev-perl/Net-Jabber )
+ ssl? ( dev-perl/IO-Socket-SSL )
+ virtual/perl-IO-Compress
+ >=dev-perl/MIME-tools-5.413
+ virtual/perl-version
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # The author of this module put a dep for MIME::Parser 6.X - but the6.X
+ # release of MIME::Parser was a mistake during a change in maintainers on
+ # cpan. This patch alters the dependancy to the "real" stable version of
+ # MIME::Parser.
+ epatch "${FILESDIR}"/SOAP-Lite-0.710.08.patch
+ # Merged upstream
+ #epatch "${FILESDIR}"/${PN}-0.712_sysread.patch
+}
+
+src_test() {
+ has_version '>=www-apache/mod_perl-2' && export MOD_PERL_API_VERSION=2
+ perl-module_src_test
+}
diff --git a/dev-perl/SOAP-Lite/metadata.xml b/dev-perl/SOAP-Lite/metadata.xml
index d4bab4cad7a6..816f3960ec09 100644
--- a/dev-perl/SOAP-Lite/metadata.xml
+++ b/dev-perl/SOAP-Lite/metadata.xml
@@ -6,8 +6,6 @@
<remote-id type="cpan">SOAP-Lite</remote-id>
<remote-id type="cpan-module">Apache::SOAP</remote-id>
<remote-id type="cpan-module">Apache::XMLRPC::Lite</remote-id>
- <remote-id type="cpan-module">IO::SessionData</remote-id>
- <remote-id type="cpan-module">IO::SessionSet</remote-id>
<remote-id type="cpan-module">LWP::Protocol</remote-id>
<remote-id type="cpan-module">My::PingPong</remote-id>
<remote-id type="cpan-module">SOAP</remote-id>