summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-07-10 16:19:01 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-07-10 16:19:01 +0000
commita6a62bf5921eb3aa48170a2b98255373a4db1e6c (patch)
tree808cb6d9e19ad23567915d338f06f7fcbdc9b45c /dev-perl
parentVersion bump. Removed old. Really fixed bug #466364 this time (diff)
downloadgentoo-2-a6a62bf5921eb3aa48170a2b98255373a4db1e6c.tar.gz
gentoo-2-a6a62bf5921eb3aa48170a2b98255373a4db1e6c.tar.bz2
gentoo-2-a6a62bf5921eb3aa48170a2b98255373a4db1e6c.zip
Initial commit, wrt bug #435062
(Portage version: 2.2.0_alpha184/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/IPTables-libiptc/ChangeLog11
-rw-r--r--dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild37
-rw-r--r--dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch24
-rw-r--r--dev-perl/IPTables-libiptc/metadata.xml13
4 files changed, 85 insertions, 0 deletions
diff --git a/dev-perl/IPTables-libiptc/ChangeLog b/dev-perl/IPTables-libiptc/ChangeLog
new file mode 100644
index 000000000000..7a46199ac4b2
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-perl/IPTables-libiptc
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/IPTables-libiptc/ChangeLog,v 1.1 2013/07/10 16:19:00 pinkbyte Exp $
+
+*IPTables-libiptc-0.520.0 (10 Jul 2013)
+
+ 10 Jul 2013; Sergey Popov <pinkbyte@gentoo.org>
+ +IPTables-libiptc-0.520.0.ebuild,
+ +files/IPTables-libiptc-0.520.0-respect-cflags.patch, +metadata.xml:
+ Initial commit, wrt bug #435062
+
diff --git a/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild b/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild
new file mode 100644
index 000000000000..18beda2ed881
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/IPTables-libiptc/IPTables-libiptc-0.520.0.ebuild,v 1.1 2013/07/10 16:19:00 pinkbyte Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=HAWK
+MODULE_VERSION=0.52
+
+inherit perl-module toolchain-funcs
+
+DESCRIPTION="Perl extension for iptables libiptc library"
+SRC_URI="${SRC_URI}
+http://dev.gentoo.org/~pinkbyte/distfiles/${PN}/${P}-support-for-iptables-1.4.12.patch.bz2
+http://dev.gentoo.org/~pinkbyte/distfiles/${PN}/${P}-support-for-iptables-1.4.16.2.patch.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# package dependency on iptables is very fragile
+# see https://rt.cpan.org/Public/Bug/Display.html?id=70639
+RDEPEND="<net-firewall/iptables-1.4.18:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${WORKDIR}/${P}-support-for-iptables-1.4.12.patch"
+ "${WORKDIR}/${P}-support-for-iptables-1.4.16.2.patch"
+ "${FILESDIR}/${P}-respect-cflags.patch"
+)
+
+# Most of tests needs root access, but they do not fail without it
+SRC_TEST="do"
+
+src_prepare() {
+ tc-export CC
+ perl-module_src_prepare
+}
diff --git a/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch b/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch
new file mode 100644
index 000000000000..9453e6623ad5
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/files/IPTables-libiptc-0.520.0-respect-cflags.patch
@@ -0,0 +1,24 @@
+--- Makefile.PL.orig 2013-07-10 19:31:29.355162000 +0400
++++ Makefile.PL 2013-07-10 19:32:28.497557436 +0400
+@@ -256,7 +256,7 @@
+ LDDLFLAGS => '-shared -L$(PREFIX)/lib',
+ ## LDDLFLAGS => '-shared $(LOCAL_LIB_IPTC) -L$(PREFIX)/lib',
+ LDFLAGS => '-L$(PREFIX)/lib',
+- DEFINE => '-g -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"\$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)',
++ DEFINE => '$(CFLAGS) -DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"\$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)',
+ # e.g., '-DHAVE_SOMETHING'
+ INC => '-I/usr/local/include -I./include -I.',
+ # e.g., '-I. -I/usr/include/other'
+
+--- iptables/Makefile.orig 2013-07-10 19:37:00.298563274 +0400
++++ iptables/Makefile 2013-07-10 19:37:16.786563628 +0400
+@@ -46,8 +46,7 @@
+ endif
+ LDLIBS=-ldl $(EXTRALIBS)
+
+-COPT_FLAGS:=-O2
+-CFLAGS:=$(COPT_FLAGS) -Wall -Wunused -I$(KERNEL_DIR)/include -I$(INCDIR) -I../include/ -fPIC -DXTABLES_INTERNAL -g
++CFLAGS+=-Wall -Wunused -I$(KERNEL_DIR)/include -I$(INCDIR) -I../include/ -fPIC -DXTABLES_INTERNAL
+ #-g -DDEBUG #-pg # -DIPTC_DEBUG
+
+ DEFINES:=-DIPTABLES_VERSION=\"$(IPTABLES_VERSION)\" -DXTABLES_LIBDIR=\"$(XTABLES_LIBDIR)\" -DIPTABLES_VERSION_CODE=\$(IPTABLES_VERSION_CODE)
diff --git a/dev-perl/IPTables-libiptc/metadata.xml b/dev-perl/IPTables-libiptc/metadata.xml
new file mode 100644
index 000000000000..cf1696c6fcb3
--- /dev/null
+++ b/dev-perl/IPTables-libiptc/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">IPTables-libiptc</remote-id>
+ <remote-id type="cpan-module">IPTables::libiptc</remote-id>
+ </upstream>
+</pkgmetadata>