summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-10-27 11:34:08 +0000
committerTorsten Veller <tove@gentoo.org>2008-10-27 11:34:08 +0000
commita986b192f5ee25f461e8906c662ded76923afc49 (patch)
treecad9dd4672c9018716743702348a0733c8f57283 /dev-perl
parentInitial commit. (diff)
downloadgentoo-2-a986b192f5ee25f461e8906c662ded76923afc49.tar.gz
gentoo-2-a986b192f5ee25f461e8906c662ded76923afc49.tar.bz2
gentoo-2-a986b192f5ee25f461e8906c662ded76923afc49.zip
Version bump
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/WWW-Mechanize/ChangeLog7
-rw-r--r--dev-perl/WWW-Mechanize/WWW-Mechanize-1.50.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-perl/WWW-Mechanize/ChangeLog b/dev-perl/WWW-Mechanize/ChangeLog
index 8fee5364bcaa..6bd9ba6f4c11 100644
--- a/dev-perl/WWW-Mechanize/ChangeLog
+++ b/dev-perl/WWW-Mechanize/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/WWW-Mechanize
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.47 2008/09/15 11:39:43 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/ChangeLog,v 1.48 2008/10/27 11:34:08 tove Exp $
+
+*WWW-Mechanize-1.50 (27 Oct 2008)
+
+ 27 Oct 2008; Torsten Veller <tove@gentoo.org> +WWW-Mechanize-1.50.ebuild:
+ Version bump
15 Sep 2008; Torsten Veller <tove@gentoo.org> -WWW-Mechanize-1.16.ebuild,
-WWW-Mechanize-1.18.ebuild, -WWW-Mechanize-1.20.ebuild,
diff --git a/dev-perl/WWW-Mechanize/WWW-Mechanize-1.50.ebuild b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.50.ebuild
new file mode 100644
index 000000000000..b24c2c56215e
--- /dev/null
+++ b/dev-perl/WWW-Mechanize/WWW-Mechanize-1.50.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/WWW-Mechanize/WWW-Mechanize-1.50.ebuild,v 1.1 2008/10/27 11:34:08 tove Exp $
+
+MODULE_AUTHOR=PETDANCE
+inherit perl-module
+
+DESCRIPTION="Handy web browsing in a Perl object"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="test"
+
+# Bug in the tests - improper use of HTTP::Server
+SRC_TEST="do"
+
+# configure to run the local tests, but not the ones which access the Internet
+myconf="--local --nolive"
+
+RDEPEND="dev-lang/perl
+ dev-perl/IO-Socket-SSL
+ >=dev-perl/libwww-perl-5.815
+ dev-perl/HTTP-Response-Encoding
+ >=dev-perl/URI-1.25
+ >=dev-perl/HTML-Parser-3.34
+ dev-perl/Test-LongString"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/Test-Pod
+ dev-perl/Test-Taint
+ dev-perl/Test-Warn
+ dev-perl/Test-Memory-Cycle )"