summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-04-08 09:21:37 +0000
committerTorsten Veller <tove@gentoo.org>2008-04-08 09:21:37 +0000
commitcaedf201f2aa4f596b19bd8bcbdb2e25c68404b2 (patch)
tree6db6c34c3836b5ac672402be45ad9ef7c0603b9d /dev-perl
parentia64/sparc stable wrt #215898 (diff)
downloadgentoo-2-caedf201f2aa4f596b19bd8bcbdb2e25c68404b2.tar.gz
gentoo-2-caedf201f2aa4f596b19bd8bcbdb2e25c68404b2.tar.bz2
gentoo-2-caedf201f2aa4f596b19bd8bcbdb2e25c68404b2.zip
Version bump. Adjust HOMEPAGE and run tests. Fix #216397.
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/extutils-pkgconfig/ChangeLog10
-rw-r--r--dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild10
-rw-r--r--dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.11.ebuild23
-rw-r--r--dev-perl/extutils-pkgconfig/metadata.xml5
4 files changed, 37 insertions, 11 deletions
diff --git a/dev-perl/extutils-pkgconfig/ChangeLog b/dev-perl/extutils-pkgconfig/ChangeLog
index 9186ced7cbaf..eb473e6dd0e4 100644
--- a/dev-perl/extutils-pkgconfig/ChangeLog
+++ b/dev-perl/extutils-pkgconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/extutils-pkgconfig
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/extutils-pkgconfig/ChangeLog,v 1.24 2007/01/15 17:45:00 mcummings Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/extutils-pkgconfig/ChangeLog,v 1.25 2008/04/08 09:21:37 tove Exp $
+
+*extutils-pkgconfig-1.11 (07 Apr 2008)
+
+ 07 Apr 2008; Torsten Veller <tove@gentoo.org>
+ extutils-pkgconfig-1.07.ebuild, +extutils-pkgconfig-1.11.ebuild:
+ Version bump. Adjust HOMEPAGE and run tests. Fix #216397.
15 Jan 2007; Michael Cummings <mcummings@gentoo.org>
extutils-pkgconfig-1.07.ebuild:
diff --git a/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild b/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild
index cf6bc6bcbe72..395eb6298409 100644
--- a/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild
+++ b/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild,v 1.13 2007/07/10 23:33:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.07.ebuild,v 1.14 2008/04/08 09:21:37 tove Exp $
inherit perl-module
MY_P=ExtUtils-PkgConfig-${PV}
S=${WORKDIR}/${MY_P}
-DESCRIPTION="Converts Perl XS code into C code"
+DESCRIPTION="Simplistic perl interface to pkg-config"
HOMEPAGE="http://search.cpan.org/~rmcfarla/"
SRC_URI="mirror://cpan/authors/id/R/RM/RMCFARLA/Gtk2-Perl/${MY_P}.tar.gz"
@@ -15,4 +15,6 @@ SLOT="0"
KEYWORDS="alpha amd64 hppa ia64 ~mips ppc ppc64 sparc x86"
IUSE=""
-DEPEND="dev-lang/perl"
+DEPEND="dev-lang/perl
+ dev-util/pkgconfig"
+RDEPEND="${DEPEND}"
diff --git a/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.11.ebuild b/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.11.ebuild
new file mode 100644
index 000000000000..151abb91efdd
--- /dev/null
+++ b/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.11.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/extutils-pkgconfig/extutils-pkgconfig-1.11.ebuild,v 1.1 2008/04/08 09:21:37 tove Exp $
+
+inherit perl-module
+
+MY_P=ExtUtils-PkgConfig-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Simplistic perl interface to pkg-config"
+HOMEPAGE="http://search.cpan.org/~tsch/ExtUtils-PkgConfig/"
+SRC_URI="mirror://cpan/authors/id/T/TS/TSCH//${MY_P}.tar.gz"
+
+LICENSE="|| ( Artistic GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl
+ dev-util/pkgconfig"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
diff --git a/dev-perl/extutils-pkgconfig/metadata.xml b/dev-perl/extutils-pkgconfig/metadata.xml
index 86672fe64c10..801e9385a1e0 100644
--- a/dev-perl/extutils-pkgconfig/metadata.xml
+++ b/dev-perl/extutils-pkgconfig/metadata.xml
@@ -2,9 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>perl</herd>
- <maintainer>
- <email>perl@gentoo.org</email>
- <description>Primary Maintainer</description>
- </maintainer>
- <longdescription></longdescription>
</pkgmetadata>